summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Steinke2015-06-08 19:47:59 +0200
committerRasmus Steinke2015-06-08 19:47:59 +0200
commitc616b03bb27a69363976e185bc3bccedbece20ea (patch)
tree159ca674a57e38f1b90e320f5fa0c6df95351403
downloadaur-c616b03bb27a69363976e185bc3bccedbece20ea.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--rofi-pass.install8
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1550e2fd5d51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rofi-pass-git
+ pkgdesc = bash script to handle pass storages in a convenient way
+ pkgver = 5.f4255a9
+ pkgrel = 1
+ url = https://github.com/carnager/rofi-pass
+ install = rofi-pass.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = xorg-xprop
+ depends = wmctrl
+ depends = rofi-git
+ depends = pass
+ depends = xdotool
+ depends = xclip
+ source = git+http://git.53280.de/rofi-pass
+ md5sums = SKIP
+
+pkgname = rofi-pass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0af5c6c9a8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Rasmus Steinke <rasi at xssn dot at>
+
+pkgname=rofi-pass-git
+_pkgname=rofi-pass
+pkgver=5.f4255a9
+pkgrel=1
+pkgdesc="bash script to handle pass storages in a convenient way"
+arch=('any')
+url='https://github.com/carnager/rofi-pass'
+license=('GPL')
+depends=('xorg-xprop' 'wmctrl' 'rofi-git' 'pass' 'xdotool' 'xclip')
+
+install=('rofi-pass.install')
+makedepends=('git')
+source=('git+http://git.53280.de/rofi-pass')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="$pkgdir/" \
+ PREFIX='/usr' \
+ install
+}
+md5sums=('SKIP')
diff --git a/rofi-pass.install b/rofi-pass.install
new file mode 100644
index 000000000000..8f3c95a0760d
--- /dev/null
+++ b/rofi-pass.install
@@ -0,0 +1,8 @@
+#!/bin/bash
+post_install() {
+echo '
+Global config file is installed in /etc/rofi-pass.conf
+To make user modifications copy it to $HOME/.config/rofi-pass/config
+'
+}
+#post_install