summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2017-11-10 23:46:28 +0100
committerBernhard Landauer2017-11-10 23:46:28 +0100
commit06b1d2a0058c4b83c459ab3eb0468f7e9c5dd264 (patch)
tree386a36c7f4a8e559fe3ea63a66e53662c98a22e2
downloadaur-roguehostapd-git.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42ebbae15d9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Nov 10 22:46:17 UTC 2017
+pkgbase = roguehostapd-git
+ pkgdesc = Hostapd Python wrapper to simplify usage of hostapd
+ pkgver = 1.0.r14.g375e3ea
+ pkgrel = 1
+ url = https://github.com/wifiphisher/roguehostapd
+ arch = any
+ license = BSD 3
+ depends = python2
+ source = git+https://github.com/wifiphisher/roguehostapd.git
+ md5sums = SKIP
+
+pkgname = roguehostapd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9774179f80fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+
+_pkgname=roguehostapd
+pkgname=$_pkgname-git
+pkgver=1.0.r14.g375e3ea
+pkgrel=1
+pkgdesc="Hostapd Python wrapper to simplify usage of hostapd"
+url="https://github.com/wifiphisher/$_pkgname"
+arch=('any')
+license=('BSD 3')
+depends=('python2')
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd $_pkgname
+ python2 setup.py install --root=$pkgdir --optimize=1
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}