summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Collins2021-04-06 20:10:24 +0200
committerMark Collins2021-04-06 20:10:24 +0200
commite9eb815ca29c937dcefda04d864c97c120f79680 (patch)
treec945fe8abe39eab8f610610985abacf964afcf0a
parente2b6a3ef96574e512a8871318540dc805be10607 (diff)
downloadaur-e9eb815ca29c937dcefda04d864c97c120f79680.tar.gz
Added post_install() info, improved file layout
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
-rw-r--r--rompr.install18
3 files changed, 42 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29e056a8883e..63654612ff9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = rompr
- pkgdesc = Web frontend to MPD
+ pkgdesc = A php web frontend to MPD and Mopidy
pkgver = 1.55
- pkgrel = 1
- url = https://github.com/fatg3erman/RompR/releases
+ pkgrel = 2
+ install = rompr.install
arch = any
license = custom
depends = imagemagick
@@ -10,12 +10,11 @@ pkgbase = rompr
depends = php-sqlite
depends = php-gd
depends = php-intl
- optdepends = apache
- optdepends = lighttpd
- optdepends = nginx
- optdepends = php-jsonreader-git: Low Memory Mode
+ optdepends = apache: webserver to serve app
+ optdepends = nginx: webserver to serve app
+ optdepends = mysql: alternate database platform to sqlite
source = https://github.com/fatg3erman/RompR/releases/download/1.55/rompr-1.55.zip
- md5sums = 23745cd02dc6e4264fe35220eec64754
+ sha256sums = 7d4ad650090e34aec9bf01f08a428768e70dacd39952bf1375295f68b320e9d3
pkgname = rompr
diff --git a/PKGBUILD b/PKGBUILD
index c586664cefb4..5455b9bd45dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,29 @@
pkgname=rompr
pkgver=1.55
-pkgrel=1
-pkgdesc="Web frontend to MPD"
+pkgrel=2
+pkgdesc="A php web frontend to MPD and Mopidy"
arch=('any')
-url="https://github.com/fatg3erman/RompR/releases"
license=('custom')
depends=('imagemagick'
- 'php'
+ 'php' # note that deps php-json, php-curl, php-xml and php-mbstring are included in php
'php-sqlite'
'php-gd'
- # 'php-json' included in php
- # 'php-curl' included in php
- # 'php-xml' included in php
- # 'php-mbstring' included in php
'php-intl')
-optdepends=('apache'
- 'lighttpd'
- 'nginx'
- 'php-jsonreader-git: Low Memory Mode')
-source=("${url}/download/${pkgver}/${pkgname}-${pkgver}.zip")
-md5sums=('23745cd02dc6e4264fe35220eec64754')
-
-build () {
- cd "${srcdir}/${pkgname}"
-}
+optdepends=('apache: webserver to serve app'
+ 'nginx: webserver to serve app'
+ 'mysql: alternate database platform to sqlite')
+source=("https://github.com/fatg3erman/RompR/releases/download/${pkgver}/${pkgname}-${pkgver}.zip")
+sha256sums=('7d4ad650090e34aec9bf01f08a428768e70dacd39952bf1375295f68b320e9d3')
+install="${pkgname}.install"
package() {
- cd "${srcdir}"
- find -name '.svn' -delete
- install -d "${pkgdir}/usr/share/webapps"
- cp -ra rompr "${pkgdir}/usr/share/webapps/"
+ cd "${srcdir}"
+ find -name '.svn' -delete
+ install -d "${pkgdir}/usr/share/webapps"
+ cp -ra "$pkgname" "${pkgdir}/usr/share/webapps/"
+ install -d "${pkgdir}/var/lib/${pkgname}/albumart"
+ ln -s "/var/lib/${pkgname}/albumart" "${pkgdir}/usr/share/webapps/${pkgname}/albumart"
+ install -d "${pkgdir}/var/lib/${pkgname}/prefs"
+ ln -s "/var/lib/${pkgname}/prefs" "${pkgdir}/usr/share/webapps/${pkgname}/prefs"
}
diff --git a/rompr.install b/rompr.install
new file mode 100644
index 000000000000..3396b2069468
--- /dev/null
+++ b/rompr.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo "Rompr has been installed"
+ echo ""
+ echo "It is a php webapp, and you now need to configure a php-capable webserver or reverse proxy to serve it."
+ echo "For Nginx instructions are at:"
+ echo "https://fatg3erman.github.io/RompR/Recommended-Installation-on-Linux"
+ echo "For Apache instructions are at:"
+ echo "https://fatg3erman.github.io/RompR/Installation-on-Linux-Alternative-Method"
+ echo ""
+ echo "Also note that the default installation uses an sqlite file to keep track of the MPD database"
+ echo "This can be substituted for mysql, instructions at:"
+ echo "https://fatg3erman.github.io/RompR/Using-a-MySQL-server"
+ echo "(however, even a 10,000+ song database results in barely a 1,5M .sq3 fileā€¦ and mysql is probably overkill here)"
+ echo ""
+ echo "Finally, once you have setup a webserver, permissions will need fixing on:"
+ echo " - /usr/share/webapps/rompr/"
+ echo " - /var/lib/rompr/"
+}