summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-21 23:29:54 +0100
committerTim Rakowski2017-12-21 23:29:54 +0100
commit6586fb9d908a4137ece117ba55d63d4171348bf1 (patch)
tree0c8667d8c1d442162a5f01917a823c67083959f8
parentfd911c42741fa1b86e78bdd33d10d12766530fa1 (diff)
downloadaur-ros-ardent-examples-rclpy-executors.tar.gz
Update to version 0.4.0-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 3 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17febe6ef9d8..92397d03f25a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Dec 19 18:41:15 UTC 2017
+# Thu Dec 21 22:29:46 UTC 2017
pkgbase = ros-ardent-examples-rclpy-executors
pkgdesc = ROS - Examples of creating and using exectors to run multiple nodes in the same process.
pkgver = 0.4.0
diff --git a/PKGBUILD b/PKGBUILD
index 62d2d0282bd3..1fdf47278234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,33 +29,7 @@ _dir="examples-release-release-ardent-examples_rclpy_executors-${pkgver}-${_pkgv
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/examples-release/archive/release/ardent/examples_rclpy_executors/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('922bb76d7dfcc2d2ad5e6541f1f47db4e803d238b006eb0681e0d9de99ccac0b')
-build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
-
- # Create build directory
- [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
- cd "${srcdir}/build"
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
-
- # Build project
- cmake "${srcdir}/${_dir}" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
- -DPYTHON_BASENAME=.cpython-35m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF \
- -DCATKIN_ENABLE_TESTING=OFF
- make
-}
-
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/${_dir}"
+ python setup.py install --root="$pkgdir" --prefix="/opt/ros/ardent" --optimize=1
}