summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commit322bf56946ff6848d495a13c0b75a4db91a29b49 (patch)
tree2dca8ac57c58fa0b27b73285182fa1907980b8e3
parent31cf7e352e43993ca641ea0ea0558e88261e6e2c (diff)
downloadaur-ros-indigo-message-runtime.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ce0365450f7..c77939bdf83e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-message-runtime
pkgdesc = ROS - Package modeling the run-time dependencies for language bindings of messages.
pkgver = 0.4.12
- pkgrel = 1
+ pkgrel = 2
url = http://ros.org/wiki/message_runtime
arch = any
license = BSD
@@ -10,9 +10,9 @@ pkgbase = ros-indigo-message-runtime
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
depends = ros-indigo-roscpp-serialization
+ depends = ros-indigo-genpy
depends = ros-indigo-rostime
depends = ros-indigo-cpp-common
- depends = ros-indigo-genpy
depends = ros-indigo-roscpp-traits
source = message_runtime::git+https://github.com/ros-gbp/message_runtime-release.git#tag=release/indigo/message_runtime/0.4.12-0
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 47562536b880..90ec02edabe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-message-runtime'
pkgver='0.4.12'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
@@ -15,9 +15,9 @@ makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=(ros-indigo-roscpp-serialization
+ ros-indigo-genpy
ros-indigo-rostime
ros-indigo-cpp-common
- ros-indigo-genpy
ros-indigo-roscpp-traits)
depends=(${ros_depends[@]})
@@ -36,16 +36,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}