summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:33:36 -0800
committerSean Greenslade2016-12-20 21:33:36 -0800
commitb42b584c1d652ecc77efa493c4ab52afeb0c9c3c (patch)
tree1ae3883cb8705d13773dd440d94480c362a671df
downloadaur-ros-kinetic-mk.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD59
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed5b989aae97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 05:33:36 UTC 2016
+pkgbase = ros-kinetic-mk
+ pkgdesc = ROS - A collection of .mk include files for building ROS architectural elements.
+ pkgver = 1.13.4
+ pkgrel = 1
+ url = http://www.ros.org/wiki/ROS
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-rosbuild
+ source = ros-kinetic-mk-1.13.4-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/kinetic/mk/1.13.4-0.tar.gz
+ sha256sums = 05c0265df7c505890e0b35321597d5a56a9ff35ca7fd6a43ecd37827543d93ac
+
+pkgname = ros-kinetic-mk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a18689228ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A collection of .mk include files for building ROS architectural elements."
+url='http://www.ros.org/wiki/ROS'
+
+pkgname='ros-kinetic-mk'
+pkgver='1.13.4'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-rosbuild)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/mk/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros-release-release-kinetic-mk-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/kinetic/mk/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('05c0265df7c505890e0b35321597d5a56a9ff35ca7fd6a43ecd37827543d93ac')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}