summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-27 12:34:19 -0800
committerSean Greenslade2016-12-27 12:34:19 -0800
commiteef4321f9a8b448f0fb9c2e9d2f9f031b60fbd7e (patch)
tree6c5c7a4b2cae847f26e103008d7e49595c6ca595
downloadaur-ros-kinetic-rosserial-python.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD62
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef5952e752d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Dec 27 20:34:19 UTC 2016
+pkgbase = ros-kinetic-rosserial-python
+ pkgdesc = ROS - A Python-based implementation of the ROS serial protocol.
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = http://ros.org/wiki/rosserial_python
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-rospy
+ depends = ros-kinetic-rosserial-msgs
+ depends = ros-kinetic-diagnostic-msgs
+ depends = python2-pyserial
+ source = ros-kinetic-rosserial-python-0.7.5-0.tar.gz::https://github.com/ros-gbp/rosserial-release/archive/release/kinetic/rosserial_python/0.7.5-0.tar.gz
+ sha256sums = 821df5b575a7e2d00091a04e3654ec482419927a7ed7f3dc81d8dc7aa1b76f96
+
+pkgname = ros-kinetic-rosserial-python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f9d25a5a8f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A Python-based implementation of the ROS serial protocol."
+url='http://ros.org/wiki/rosserial_python'
+
+pkgname='ros-kinetic-rosserial-python'
+pkgver='0.7.5'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-rospy
+ ros-kinetic-rosserial-msgs
+ ros-kinetic-diagnostic-msgs)
+depends=(${ros_depends[@]}
+ python2-pyserial)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/rosserial_python/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rosserial-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rosserial-release-release-kinetic-rosserial_python-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rosserial-release/archive/release/kinetic/rosserial_python/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('821df5b575a7e2d00091a04e3654ec482419927a7ed7f3dc81d8dc7aa1b76f96')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}