summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorachterin2015-07-15 11:31:24 +0200
committerachterin2015-07-15 11:31:24 +0200
commit36f0f10a138b32c3c445a1183e3bda07da3a9fce (patch)
treeeda14e5c4ae5539b833c74185d46efd70d4e85db
downloadaur-roundcube-contextmenu-plugin.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b582f410ec2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by makepkg 4.2.1
+# Sun Jul 12 17:12:30 UTC 2015
+pkgbase = roundcube-contextmenu-plugin
+ pkgdesc = This plugin adds context menus to the message list, folder list and address book.
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = http://www.tehinterweb.co.uk/roundcube/#picontextmenu
+ arch = any
+ license = GPL
+ depends = roundcubemail>=1.1.0
+ source = https://github.com/JohnDoh/Roundcube-Plugin-Context-Menu/archive/2.1.2.tar.gz
+ md5sums = fdda9008c9c0de15ce0156b37258c087
+
+pkgname = roundcube-contextmenu-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ba42f69e712
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: achterin
+
+pkgname=roundcube-contextmenu-plugin
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="This plugin adds context menus to the message list, folder list and address book."
+arch=('any')
+url="http://www.tehinterweb.co.uk/roundcube/#picontextmenu"
+license=('GPL')
+depends=('roundcubemail>=1.1.0')
+source=(https://github.com/JohnDoh/Roundcube-Plugin-Context-Menu/archive/2.1.2.tar.gz)
+md5sums=('fdda9008c9c0de15ce0156b37258c087')
+
+package() {
+ _instdir=${pkgdir}/usr/share/webapps/roundcubemail/plugins
+ install -dm755 ${_instdir}
+ cp -r ${srcdir}/Roundcube-Plugin-Context-Menu-${pkgver} ${_instdir}/contextmenu
+
+ # fix all the 644 perms on files
+ find ${_instdir} -type f -exec chmod 644 {} \;
+}