summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-06 04:45:14 +0800
committerChocobo12023-04-06 04:45:14 +0800
commit9855bde7d5530ddaa73987a72bd22df0a3689d87 (patch)
treefe3cbcb80fba79315f3ab29046a5f89cce61d63c
parent9a368eecdbcd3214c6e85076e98c3a82b9cc8b3a (diff)
downloadaur-routinator-git.tar.gz
upgpkg: routinator-git 0.12.1.r14.gd9191fd-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e574436df90..ef060259617a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = routinator-git
pkgdesc = RPKI validator written in Rust
- pkgver = 0.11.2.r1.g3029722
+ pkgver = 0.12.1.r14.gd9191fd
pkgrel = 1
url = https://nlnetlabs.nl/rpki
arch = i686
@@ -10,7 +10,7 @@ pkgbase = routinator-git
makedepends = rust
depends = gcc-libs
depends = rsync
- provides = routinator=0.11.2.r1.g3029722
+ provides = routinator=0.12.1.r14.gd9191fd
conflicts = routinator
backup = etc/routinator/routinator.conf
source = git+https://github.com/NLnetLabs/routinator.git
diff --git a/PKGBUILD b/PKGBUILD
index 42d035ac4df1..28381a62b914 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=routinator-git
-pkgver=0.11.2.r1.g3029722
+pkgver=0.12.1.r14.gd9191fd
pkgrel=1
pkgdesc="RPKI validator written in Rust"
arch=('i686' 'x86_64')
@@ -16,6 +16,15 @@ source=("git+https://github.com/NLnetLabs/routinator.git")
sha256sums=('SKIP')
+prepare() {
+ cd "routinator"
+
+ if [ ! -f "Cargo.lock" ]; then
+ cargo update
+ fi
+ cargo fetch
+}
+
pkgver() {
cd "routinator"
@@ -29,18 +38,17 @@ check() {
cd "routinator"
cargo test \
- --release \
- --locked
+ --frozen
}
package() {
cd "routinator"
cargo install \
- --no-track \
--locked \
+ --no-track \
--root "$pkgdir/usr" \
- --path "$srcdir/routinator"
+ --path .
install -Dm755 "pkg/common/routinator-init" -t "$pkgdir/usr/bin"
install -Dm644 "etc/routinator.conf.example" -t "$pkgdir/etc/routinator"