summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2021-04-11 21:30:21 +0200
committerCarsten Teibes2021-04-11 21:30:21 +0200
commit8fa86aaa3d75f7fcc7d437895813966591b60799 (patch)
treef2ef8a7dc85a897f62741d8eaed10dec995849ab
parent273b7f28b3682b8391f95ddc119fffb45c6c1148 (diff)
downloadaur-rpg2000-rtp.tar.gz
[upd] new urls
[fix] extract with right encoding instead of renaming afterwards [fix] no more need to set environment variables
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD43
-rw-r--r--rpg2000-rtp.sh10
3 files changed, 25 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd9988d7fbf7..8c4cf8c3c973 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = rpg2000-rtp
pkgdesc = RPG Maker 2000 Runtime Package (Japanese)
pkgver = 201906
- pkgrel = 1
- url = https://tkool.jp/support/download/rpg2000/rtp
+ pkgrel = 2
+ url = https://tkool.jp/products/rtp.html
arch = any
license = custom: commercial
- makedepends = unshield-git
- makedepends = convmv
+ makedepends = unshield
+ makedepends = unarchiver
makedepends = glibc
optdepends = easyrpg-player: game engine for using the RTP
noextract = 2000rtp.zip
- source = https://tkool.jp/assets/files/2000rtp.zip
+ noextract = RTP_patchk_190612.zip
+ source = https://tkool.jp/products/rtp/2000rtp.zip
source = https://tkool.jp/products/rtp/RTP_patchk_190612.zip
- source = rpg2000-rtp.sh
sha256sums = c130f0078c0d6ecc3404f94af8258e4557ab85c3b204397c7f21dbc57efeef8e
sha256sums = 3041c57af04675b990da5709928fe7794cac2e4b21f6b526a81d310b353db3ad
- sha256sums = 1a892b64ea2df5827e560100408d6ff3f8abc9ec008f62bc8167fb91c0c2b5da
pkgname = rpg2000-rtp
diff --git a/PKGBUILD b/PKGBUILD
index 4e16962f54fc..a85843b220ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,32 @@
pkgname=rpg2000-rtp
pkgver=201906
-pkgrel=1
+pkgrel=2
pkgdesc="RPG Maker 2000 Runtime Package (Japanese)"
arch=('any')
-url="https://tkool.jp/support/download/rpg2000/rtp"
+url="https://tkool.jp/products/rtp.html"
license=('custom: commercial')
-makedepends=('unshield-git' 'convmv' 'glibc')
+makedepends=('unshield' 'unarchiver' 'glibc')
optdepends=('easyrpg-player: game engine for using the RTP')
-source=("https://tkool.jp/assets/files/2000rtp.zip"
- "https://tkool.jp/products/rtp/RTP_patchk_190612.zip"
- "$pkgname.sh")
+source=("https://tkool.jp/products/rtp/2000rtp.zip"
+ "https://tkool.jp/products/rtp/RTP_patchk_190612.zip")
sha256sums=('c130f0078c0d6ecc3404f94af8258e4557ab85c3b204397c7f21dbc57efeef8e'
- '3041c57af04675b990da5709928fe7794cac2e4b21f6b526a81d310b353db3ad'
- '1a892b64ea2df5827e560100408d6ff3f8abc9ec008f62bc8167fb91c0c2b5da')
-noextract=('2000rtp.zip')
+ '3041c57af04675b990da5709928fe7794cac2e4b21f6b526a81d310b353db3ad')
+noextract=('2000rtp.zip' 'RTP_patchk_190612.zip')
prepare() {
- # extract
- bsdtar --strip-components 1 --include='*.exe' -xf 2000rtp.zip
- bsdtar --include='*.txt' -O -xf 2000rtp.zip > TOS-sjis.txt
- bsdtar -xf RPG2000RTP.exe
- unshield -R -d rtp x data1.cab
# cleanup
- rm -rf rtp/_*
- convmv -f SHIFT-JIS -t UTF-8 -r --qfrom --notest rtp
- iconv -f SHIFT-JIS -t UTF-8 TOS-sjis.txt > TOS.txt
+ rm -rf "RTPセットアップ" RPG2000RTP rtp 2000 RTP_patchk_190612
+ # extract
+ unar -e ms932 2000rtp.zip
+ unar "RTPセットアップ"/RPG2000RTP.exe
+ unshield -e ms932 -d rtp x RPG2000RTP/data1.cab
+ unar -e ms932 RTP_patchk_190612.zip
mv rtp/"RPGツクール2000_ランタイムパッケージ" 2000
- convmv -f SHIFT-JIS -t UTF-8 -r --qfrom --notest RTP_patchk_190612
- iconv -f SHIFT-JIS -t UTF-8 RTP_patchk_190612/"RTPの修正ファイルについて.txt" > PatchNotes.txt
- # patch
+ # convert text
+ iconv -f ms932 -t UTF-8 "RTPセットアップ/使用規約.txt" > "使用規約.txt"
+ iconv -f ms932 -t UTF-8 RTP_patchk_190612/"RTPの修正ファイルについて.txt" > "RTPの修正ファイルについて.txt"
+ # apply patch
mv RTP_patchk_190612/"モンスター.png" 2000/RTP/FaceSet
mv RTP_patchk_190612/"主人公3.png" 2000/RTP/CharSet
mv RTP_patchk_190612/{"基本","ダンジョン","船","内装","外観"}.png 2000/RTP/ChipSet
@@ -43,10 +40,8 @@ package() {
# sane permissions
find "$pkgdir"/usr/share/rtp -type d -exec chmod 0755 {} \;
find "$pkgdir"/usr/share/rtp -type f -exec chmod 0644 {} \;
- # export environment variables
- install -Dm0755 $pkgname.sh "$pkgdir"/etc/profile.d/$pkgname.sh
# license
- install -Dm0644 TOS.txt "$pkgdir"/usr/share/licenses/$pkgname/TOS.txt
+ install -Dm0644 "使用規約.txt" -t "$pkgdir"/usr/share/licenses/$pkgname
# patch doc
- install -Dm0644 PatchNotes.txt "$pkgdir"/usr/share/doc/$pkgname/"Patch Notes.txt"
+ install -Dm0644 "RTPの修正ファイルについて.txt" -t "$pkgdir"/usr/share/doc/$pkgname
}
diff --git a/rpg2000-rtp.sh b/rpg2000-rtp.sh
deleted file mode 100644
index 49909e79e4b3..000000000000
--- a/rpg2000-rtp.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-RTP=/usr/share/rtp/2000
-
-if [ -z "$RPG2K_RTP_PATH" ]; then
- RPG2K_RTP_PATH=$RTP
-else
- # add to end of path list
- RPG2K_RTP_PATH=${RPG2K_RTP_PATH}:$RTP
-fi
-
-export RPG2K_RTP_PATH