summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordequis2017-12-24 14:18:42 -0300
committerdequis2017-12-24 14:18:42 -0300
commit0edf731bf3f56cd3c3ffb316ae5d1781e542d57b (patch)
tree2ae4082bfadf21186f21be9eb6be8271d30cbc8a
parentac803003f37ad2dbe5be0e2c592cfe3ac09506c4 (diff)
downloadaur-0edf731bf3f56cd3c3ffb316ae5d1781e542d57b.tar.gz
5.1.0, add capnproto dep
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 11 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcadd3ab3246..9086cfc54b77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jun 10 15:50:30 UTC 2017
+# Sun Dec 24 17:18:19 UTC 2017
pkgbase = rr
pkgdesc = Record and Replay framework: lightweight recording and deterministic debugging
- pkgver = 4.5.0
- pkgrel = 4
+ pkgver = 5.1.0
+ pkgrel = 1
url = http://rr-project.org/
arch = i686
arch = x86_64
@@ -13,14 +13,9 @@ pkgbase = rr
makedepends = gdb
depends = python2-pexpect
depends = gdb
- source = https://github.com/mozilla/rr/archive/4.5.0.tar.gz
- source = https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch
- source = https://github.com/mozilla/rr/commit/5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
- source = https://github.com/mozilla/rr/commit/94685aa9eb3531c42932f8ceabe40bd06cebe606.patch
- sha1sums = 70d3902c36fb1d0cd423cf1046df06f5153cba5b
- sha1sums = e05f9c5081cb67b53d730097731fa382a1bb0194
- sha1sums = cee1884633ecd377a6ca0c7cfcfe2ae257c0876a
- sha1sums = 7724dbd8c1231410c62a7779ef480857c661882a
+ depends = capnproto
+ source = https://github.com/mozilla/rr/archive/5.1.0.tar.gz
+ sha1sums = ee3f1f99776ba5525822d18affa66a8a917b7827
pkgname = rr
diff --git a/PKGBUILD b/PKGBUILD
index 60efd8376cff..c08c979301a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,21 @@
# Previous maintainer: Joel Teichroeb <joel@teichroeb.net>
pkgname=rr
-pkgver=4.5.0
-pkgrel=4
+pkgver=5.1.0
+pkgrel=1
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
license=('custom')
-depends=('python2-pexpect' 'gdb')
+depends=('python2-pexpect' 'gdb' 'capnproto')
makedepends=('git' 'cmake' 'gdb')
[ "$CARCH" = 'x86_64' ] && makedepends+=('gcc-multilib')
-source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
- https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch
- https://github.com/mozilla/rr/commit/5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
- https://github.com/mozilla/rr/commit/94685aa9eb3531c42932f8ceabe40bd06cebe606.patch)
-sha1sums=('70d3902c36fb1d0cd423cf1046df06f5153cba5b'
- 'e05f9c5081cb67b53d730097731fa382a1bb0194'
- 'cee1884633ecd377a6ca0c7cfcfe2ae257c0876a'
- '7724dbd8c1231410c62a7779ef480857c661882a')
+source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz)
+sha1sums=('ee3f1f99776ba5525822d18affa66a8a917b7827')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
-
- # -Werror fixes
- patch -p1 -i ../2001.patch
- # "Newer versions of glibc are deprecating the implicit sys/sysmacros.h
- # include via sys/types.h, so include it explicitly"
- patch -p1 -i ../5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
-
- # GCC 7 build errors (PR 2036)
- patch -p1 -i ../94685aa9eb3531c42932f8ceabe40bd06cebe606.patch
}
build() {