summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody Schafer2020-11-16 17:25:53 -0500
committerCody Schafer2020-11-16 17:25:53 -0500
commit50ed912afa3eead2480637218f86d1c0463924eb (patch)
tree39d9a7def61c3072a3777f9feb06cc11433a6846
parent1fe487e489a5fae9e149f3112121a985013e26b5 (diff)
downloadaur-50ed912afa3eead2480637218f86d1c0463924eb.tar.gz
add patch 2726 to fix clang builds (thanks konsonanz)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 853c7059219f..027c31c7482e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rr
pkgdesc = Record and Replay framework: lightweight recording and deterministic debugging
pkgver = 5.4.0
- pkgrel = 5
+ pkgrel = 6
url = http://rr-project.org/
arch = i686
arch = x86_64
@@ -14,7 +14,9 @@ pkgbase = rr
depends = capnproto
options = !strip
source = rr-5.4.0.tar.gz::https://github.com/rr-debugger/rr/archive/5.4.0.tar.gz
+ source = https://patch-diff.githubusercontent.com/raw/rr-debugger/rr/pull/2726.diff
sha1sums = b4716dd10b01ae4b8d35ae08f4f67fc46f0693d9
+ sha1sums = 80abae19e4486df97e922dcc7a906b96a1e00bc3
pkgname = rr
diff --git a/PKGBUILD b/PKGBUILD
index 023a46cdfe27..d8ea66440913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rr
pkgver=5.4.0
-pkgrel=5
+pkgrel=6
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -15,11 +15,14 @@ options=(!strip)
source=(
$pkgname-$pkgver.tar.gz::https://github.com/rr-debugger/${pkgname}/archive/${pkgver}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/rr-debugger/rr/pull/2726.diff
)
-sha1sums=('b4716dd10b01ae4b8d35ae08f4f67fc46f0693d9')
+sha1sums=('b4716dd10b01ae4b8d35ae08f4f67fc46f0693d9'
+ '80abae19e4486df97e922dcc7a906b96a1e00bc3')
prepare() {
cd $pkgname-$pkgver
+ patch -Np1 -i $srcdir/2726.patch
mkdir -p build
}