summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2018-11-18 12:32:26 -0500
committerCody P Schafer2018-11-18 12:32:26 -0500
commit57f71c11aa00d7953820a646568ef29cfac43447 (patch)
tree6f971010cd897e28d1f0e918f1ae87abeb36f586
parent75481b965392f67b2283ef9154f34fd9d51bc17c (diff)
downloadaur-57f71c11aa00d7953820a646568ef29cfac43447.tar.gz
add missing file
-rw-r--r--0001-avoid-overriding-external-opt-debug-flags.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/0001-avoid-overriding-external-opt-debug-flags.patch b/0001-avoid-overriding-external-opt-debug-flags.patch
new file mode 100644
index 000000000000..0f75ca1f7b09
--- /dev/null
+++ b/0001-avoid-overriding-external-opt-debug-flags.patch
@@ -0,0 +1,35 @@
+From 9c30d17783891bbe2bc8715a5cf3699c322b0712 Mon Sep 17 00:00:00 2001
+From: Cody P Schafer <dev@codyps.com>
+Date: Sun, 18 Nov 2018 12:25:05 -0500
+Subject: [PATCH] avoid overriding external opt/debug flags
+
+---
+ CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index caad1f19..5ebc6998 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,15 +38,15 @@ set(rr_VERSION_PATCH 0)
+
+ add_definitions(-DRR_VERSION="${rr_VERSION_MAJOR}.${rr_VERSION_MINOR}.${rr_VERSION_PATCH}")
+
+-set(FLAGS_COMMON "-msse2 -D__MMX__ -D__SSE__ -D__SSE2__ -D__USE_LARGEFILE64 -pthread -g3")
++set(FLAGS_COMMON "-msse2 -D__MMX__ -D__SSE__ -D__SSE2__ -D__USE_LARGEFILE64 -pthread")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${FLAGS_COMMON} -Wstrict-prototypes -std=gnu11")
+ # Define __STDC_LIMIT_MACROS so |#include <stdint.h>| works as expected.
+ # Define __STDC_FORMAT_MACROS so |#include <inttypes.h>| works as expected.
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${FLAGS_COMMON} -D__STDC_LIMIT_MACROS -D__STDC_FORMAT_MACROS -std=c++11")
+-set(CMAKE_ASM_FLAGS "${CMAKE_ASM_FLAGS} -g3")
++set(CMAKE_ASM_FLAGS "${CMAKE_ASM_FLAGS}")
+
+ set(RR_FLAGS_DEBUG "-Wall -Wextra -Werror -O0 -DDEBUG -UNDEBUG")
+-set(RR_FLAGS_RELEASE "-Wall -Wextra -O2 -UDEBUG -DNDEBUG")
++set(RR_FLAGS_RELEASE "-Wall -Wextra -UDEBUG -DNDEBUG")
+ set(RR_TEST_FLAGS "${RR_FLAGS_DEBUG}")
+
+ string(TOLOWER ${CMAKE_BUILD_TYPE} LOWERCASE_CMAKE_BUILD_TYPE)
+--
+2.19.1
+