summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordequis2017-03-21 17:28:57 -0300
committerdequis2017-03-21 17:28:57 -0300
commit9fcdfe5006945345c778d77a25816f1d3552c636 (patch)
tree05522f5444b3cec43bdb40f9d7cb0647ffa45b64
parent09319231ef53a3656302d089b6521f98d55df306 (diff)
downloadaur-9fcdfe5006945345c778d77a25816f1d3552c636.tar.gz
Add patch fixing build with glibc 2.25
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 177ba1f3c979..d84df3b6b718 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Mar 21 07:25:21 UTC 2017
+# Tue Mar 21 20:28:48 UTC 2017
pkgbase = rr
pkgdesc = Record and Replay framework: lightweight recording and deterministic debugging
pkgver = 4.5.0
- pkgrel = 2
+ pkgrel = 3
url = http://rr-project.org/
arch = i686
arch = x86_64
@@ -15,8 +15,10 @@ pkgbase = rr
depends = gdb
source = https://github.com/mozilla/rr/archive/4.5.0.tar.gz
source = https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch
+ source = https://github.com/mozilla/rr/commit/5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
sha1sums = 70d3902c36fb1d0cd423cf1046df06f5153cba5b
sha1sums = 51dba5dbbe16c3631a101409a28247075668fe7b
+ sha1sums = 401ca2e7108fc305c6644c2d27a86fdb24855fb1
pkgname = rr
diff --git a/PKGBUILD b/PKGBUILD
index d5e76a2f5f72..c9d5e094d4eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rr
pkgver=4.5.0
-pkgrel=2
+pkgrel=3
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -12,9 +12,11 @@ depends=('python2-pexpect' 'gdb')
makedepends=('git' 'cmake' 'gdb')
[ "$CARCH" = 'x86_64' ] && makedepends+=('gcc-multilib')
source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
- https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch)
+ https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch
+ https://github.com/mozilla/rr/commit/5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch)
sha1sums=('70d3902c36fb1d0cd423cf1046df06f5153cba5b'
- '51dba5dbbe16c3631a101409a28247075668fe7b')
+ '51dba5dbbe16c3631a101409a28247075668fe7b'
+ '401ca2e7108fc305c6644c2d27a86fdb24855fb1')
prepare() {
cd $pkgname-$pkgver
@@ -22,6 +24,9 @@ prepare() {
# -Werror fixes
patch -p1 -i ../2001.patch
+ # "Newer versions of glibc are deprecating the implicit sys/sysmacros.h
+ # include via sys/types.h, so include it explicitly"
+ patch -p1 -i ../5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
}
build() {