summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordequis2017-06-10 12:50:46 -0300
committerdequis2017-06-10 12:50:46 -0300
commitac803003f37ad2dbe5be0e2c592cfe3ac09506c4 (patch)
treeb4d3e95d504b19274b951296e2c2a56f768e5786
parentc6fc19c8f00d2956e9d40bef830a5fd6a530d8ac (diff)
downloadaur-ac803003f37ad2dbe5be0e2c592cfe3ac09506c4.tar.gz
Add GCC 7 build errors fix patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d84df3b6b718..fcadd3ab3246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Mar 21 20:28:48 UTC 2017
+# Sat Jun 10 15:50:30 UTC 2017
pkgbase = rr
pkgdesc = Record and Replay framework: lightweight recording and deterministic debugging
pkgver = 4.5.0
- pkgrel = 3
+ pkgrel = 4
url = http://rr-project.org/
arch = i686
arch = x86_64
@@ -16,9 +16,11 @@ pkgbase = rr
source = https://github.com/mozilla/rr/archive/4.5.0.tar.gz
source = https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch
source = https://github.com/mozilla/rr/commit/5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
+ source = https://github.com/mozilla/rr/commit/94685aa9eb3531c42932f8ceabe40bd06cebe606.patch
sha1sums = 70d3902c36fb1d0cd423cf1046df06f5153cba5b
- sha1sums = 51dba5dbbe16c3631a101409a28247075668fe7b
- sha1sums = 401ca2e7108fc305c6644c2d27a86fdb24855fb1
+ sha1sums = e05f9c5081cb67b53d730097731fa382a1bb0194
+ sha1sums = cee1884633ecd377a6ca0c7cfcfe2ae257c0876a
+ sha1sums = 7724dbd8c1231410c62a7779ef480857c661882a
pkgname = rr
diff --git a/PKGBUILD b/PKGBUILD
index 51d6b346e348..60efd8376cff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rr
pkgver=4.5.0
-pkgrel=3
+pkgrel=4
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -13,10 +13,12 @@ makedepends=('git' 'cmake' 'gdb')
[ "$CARCH" = 'x86_64' ] && makedepends+=('gcc-multilib')
source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch
- https://github.com/mozilla/rr/commit/5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch)
+ https://github.com/mozilla/rr/commit/5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
+ https://github.com/mozilla/rr/commit/94685aa9eb3531c42932f8ceabe40bd06cebe606.patch)
sha1sums=('70d3902c36fb1d0cd423cf1046df06f5153cba5b'
'e05f9c5081cb67b53d730097731fa382a1bb0194'
- 'cee1884633ecd377a6ca0c7cfcfe2ae257c0876a')
+ 'cee1884633ecd377a6ca0c7cfcfe2ae257c0876a'
+ '7724dbd8c1231410c62a7779ef480857c661882a')
prepare() {
cd $pkgname-$pkgver
@@ -27,6 +29,9 @@ prepare() {
# "Newer versions of glibc are deprecating the implicit sys/sysmacros.h
# include via sys/types.h, so include it explicitly"
patch -p1 -i ../5a16d15ef348c069b82449dcdeaeea3c1eb8639b.patch
+
+ # GCC 7 build errors (PR 2036)
+ patch -p1 -i ../94685aa9eb3531c42932f8ceabe40bd06cebe606.patch
}
build() {