summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2019-12-04 00:55:13 -0500
committerCody P Schafer2019-12-04 00:55:13 -0500
commite801137554957efc1c301c7add0a7e4d6ee08e43 (patch)
treebab652fb06a54be366a6dd3d6e6cff90a04cf745
parentb4ddcd3be38a6725659be4b8148999a53b18c9a2 (diff)
downloadaur-e801137554957efc1c301c7add0a7e4d6ee08e43.tar.gz
disable stripping
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26d3eed829ba..db79038f0228 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rr
pkgdesc = Record and Replay framework: lightweight recording and deterministic debugging
pkgver = 5.2.0
- pkgrel = 4
+ pkgrel = 5
url = http://rr-project.org/
arch = i686
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = rr
makedepends = ninja
depends = gdb
depends = capnproto
+ options = !strip
source = rr-5.2.0.tar.gz::https://github.com/mozilla/rr/archive/5.2.0.tar.gz
source = https://github.com/mozilla/rr/commit/53c5bd72bae089616a3ca626b8af240481d70e6f.patch
source = file://0001-avoid-overriding-external-opt-debug-flags.patch
diff --git a/PKGBUILD b/PKGBUILD
index e1a3a16d946b..bac61224ee66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,15 @@
pkgname=rr
pkgver=5.2.0
-pkgrel=4
+pkgrel=5
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
license=('custom')
depends=('gdb' 'capnproto')
makedepends=('git' 'cmake' 'gdb' 'ninja')
+options=(!strip)
+
source=(
$pkgname-$pkgver.tar.gz::https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
https://github.com/mozilla/rr/commit/53c5bd72bae089616a3ca626b8af240481d70e6f.patch
@@ -46,6 +48,9 @@ build() {
package() {
cd $pkgname-$pkgver/build
DESTDIR="${pkgdir}" cmake --build . -- -v install
+ if check_option 'debug' n; then
+ find "${pkgdir}/usr/bin" -type f -executable -exec strip $STRIP_BINARIES {} + || :
+ fi
cd ..
install -D LICENSE "${pkgdir}/usr/share/licenses/rr/LICENSE"
}