summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-02 19:16:10 +0000
committerDaniel Bermond2019-06-02 19:16:10 +0000
commit0c7ed12607696b564948dceb7ffcfbe57fc29d95 (patch)
treee19c5ba2f642095a325dd5edc1d55d499979c9a9
parentf32dc2bdc0e982f70445026b7624d34164734fc7 (diff)
downloadaur-rtmpdump-git.tar.gz
Update pkgver method. Update dependencies. Cosmetic changes.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD47
2 files changed, 35 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53215044ae5d..b14a6ad8a3f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
-# Generated by mksrcinfo v8
-# Wed Jun 14 05:06:32 UTC 2017
pkgbase = rtmpdump-git
- pkgdesc = A tool to download rtmp and rtmpe streams
- pkgver = 0.512.fa8646d
+ pkgdesc = A tool to download rtmp and rtmpe streams (git version)
+ pkgver = 2.4.r98.gc5f04a5
pkgrel = 1
url = http://rtmpdump.mplayerhq.hu/
- arch = i686
arch = x86_64
license = GPL2
license = LGPL2.1
makedepends = git
+ depends = glibc
depends = gnutls
+ depends = zlib
+ depends = nettle
+ depends = gmp
provides = rtmpdump
+ provides = librtmp.so
conflicts = rtmpdump
- source = git+git://git.ffmpeg.org/rtmpdump
+ source = git+https://git.ffmpeg.org/rtmpdump
md5sums = SKIP
pkgname = rtmpdump-git
diff --git a/PKGBUILD b/PKGBUILD
index 72d60076dfc1..0446d6b298ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,49 @@
-# Maintainer: Christopher Rosell <chrippa@gmail.com>
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Contributor: Christopher Rosell <chrippa@gmail.com>
# Contributor: Army
# Contributor: tomegun
pkgname=rtmpdump-git
-pkgver=0.512.fa8646d
+pkgver=2.4.r98.gc5f04a5
pkgrel=1
-pkgdesc="A tool to download rtmp and rtmpe streams"
-url="http://rtmpdump.mplayerhq.hu/"
-arch=('i686' 'x86_64')
+pkgdesc='A tool to download rtmp and rtmpe streams (git version)'
+url='http://rtmpdump.mplayerhq.hu/'
+arch=('x86_64')
license=('GPL2' 'LGPL2.1')
-depends=('gnutls')
+depends=('glibc' 'gnutls' 'zlib' 'nettle' 'gmp')
makedepends=('git')
-provides=('rtmpdump')
+provides=('rtmpdump' 'librtmp.so')
conflicts=('rtmpdump')
-source=("git+git://git.ffmpeg.org/rtmpdump")
+source=('git+https://git.ffmpeg.org/rtmpdump')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/rtmpdump"
- echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+ cd rtmpdump
+
+ local _version
+ local _ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
+ local _revision
+ local _shorthash
+
+ _version="$(grep '^VERSION=' Makefile | sed 's/.*=v//')"
+ _revision="$(git rev-list --count "$_ver_commit"..HEAD)"
+ _shorthash="$(git rev-parse --short HEAD)"
+
+ printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- cd "$srcdir/rtmpdump"
+ cd rtmpdump
sed -e 's/^CRYPTO=OPENSSL/#CRYPTO=OPENSSL/' -e 's/#CRYPTO=GNUTLS/CRYPTO=GNUTLS/' -i Makefile -i librtmp/Makefile
make OPT="$CFLAGS" XLDFLAGS="$LDFLAGS"
}
package() {
- cd "$srcdir/rtmpdump"
-
- install -dm755 "$pkgdir/usr/lib"
-
- make prefix=/usr \
- sbindir=/usr/bin \
- mandir=/usr/share/man \
+ cd rtmpdump
+ mkdir -p "${pkgdir}/usr/lib"
+ make prefix='/usr' \
+ sbindir='/usr/bin' \
+ mandir='/usr/share/man' \
DESTDIR="$pkgdir" \
install
}
-
-# vim:set ts=2 sw=2 et: