summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Rustand2019-07-21 17:50:09 +0200
committerLars Rustand2019-07-21 18:01:16 +0200
commit20e806deac7fd878ad5f181e13d9ce325c05d0bc (patch)
tree984790e87100ec742aa05a62dae0ccc0114560d3
parent72b6d84c84b4f297fc4cf9bb5695586c001e7162 (diff)
downloadaur-rtorrent-color.tar.gz
Updated to 0.9.8
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--rtorrent-0.9.8_color.patch (renamed from rtorrent-0.9.6_color.patch)306
3 files changed, 172 insertions, 162 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ba159745451..e0ca10265d0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rtorrent-color
pkgdesc = Ncurses BitTorrent client based on libTorrent with color patch.
- pkgver = 0.9.6
- pkgrel = 4
+ pkgver = 0.9.8
+ pkgrel = 1
url = https://github.com/KopfKrieg/rtorrent/tree/colorpatch
install = rtorrent-color.install
arch = i686
@@ -13,10 +13,10 @@ pkgbase = rtorrent-color
depends = libsigc++
provides = rtorrent
conflicts = rtorrent
- source = rtorrent-color-0.9.6.tar.gz::https://github.com/rakshasa/rtorrent/archive/0.9.6.tar.gz
- source = rtorrent-0.9.6_color.patch
- sha1sums = 27505081254618077c291eb1ee36bfb41f974834
- sha1sums = 78429b5cf5976270dc1a55d8dc0ef4644675512b
+ source = rtorrent-color-0.9.8.tar.gz::https://github.com/rakshasa/rtorrent/releases/download/v0.9.8/rtorrent-0.9.8.tar.gz
+ source = rtorrent-0.9.8_color.patch
+ sha1sums = ed4f150ea8bb8f57af2042190512391a118e2302
+ sha1sums = 717357e7a06fb1f3a7a873fb18c2077488fcf2c7
pkgname = rtorrent-color
diff --git a/PKGBUILD b/PKGBUILD
index 34df035279e3..5da5faf1f722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=rtorrent-color
_pkgname="rtorrent"
-pkgver=0.9.6
-pkgrel=4
+pkgver=0.9.8
+pkgrel=1
pkgdesc="Ncurses BitTorrent client based on libTorrent with color patch."
url="http://rakshasa.github.io/rtorrent/"
url="https://github.com/KopfKrieg/rtorrent/tree/colorpatch"
@@ -16,25 +16,25 @@ depends=("curl" "libtorrent>=0.13.6" "xmlrpc-c" "libsigc++")
conflicts=("${_pkgname}")
provides=("${_pkgname}")
install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rakshasa/${_pkgname}/archive/${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rakshasa/${_pkgname}/releases/download/v${pkgver}/rtorrent-${pkgver}.tar.gz"
"${_pkgname}-${pkgver}_color.patch")
-sha1sums=('27505081254618077c291eb1ee36bfb41f974834'
- '78429b5cf5976270dc1a55d8dc0ef4644675512b')
+sha1sums=('ed4f150ea8bb8f57af2042190512391a118e2302'
+ '15f4885924cf74bb97c87a14c0c2f6d9c8c4c6db')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -uNp1 -i "${srcdir}/${_pkgname}-${pkgver}_color.patch"
-
+
sed '/AM_PATH_CPPUNIT/d' -i configure.ac
./autogen.sh
-
+
export CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
./configure \
--prefix=/usr \
--enable-debug \
--with-xmlrpc-c \
-
+
make
}
diff --git a/rtorrent-0.9.6_color.patch b/rtorrent-0.9.8_color.patch
index 9595b83fafe0..a9184d574c1f 100644
--- a/rtorrent-0.9.6_color.patch
+++ b/rtorrent-0.9.8_color.patch
@@ -1,55 +1,60 @@
-diff --git a/src/command_network.cc b/src/command_network.cc
-index c445c38..24ad5c0 100644
---- a/src/command_network.cc
-+++ b/src/command_network.cc
-@@ -241,6 +241,26 @@ initialize_command_network() {
- CMD2_ANY ("strings.connection_type", tr1::bind(&torrent::option_list_strings, torrent::OPTION_CONNECTION_TYPE));
- CMD2_ANY ("strings.encryption", tr1::bind(&torrent::option_list_strings, torrent::OPTION_ENCRYPTION));
+diff '--color=auto' -ru rtorrent-0.9.8/src/command_network.cc rtorrent-0.9.8_patched/src/command_network.cc
+--- rtorrent-0.9.8/src/command_network.cc 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/command_network.cc 2019-07-21 15:42:43.880345353 +0200
+@@ -237,6 +237,27 @@
-+ CMD2_ANY ("colors.color_inactive_fg", tr1::bind(&ui::Root::get_color_inactive_fg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_inactive_fg.set", tr1::bind(&ui::Root::set_color_inactive_fg, control->ui(), tr1::placeholders::_2));
-+ CMD2_ANY ("colors.color_inactive_bg", tr1::bind(&ui::Root::get_color_inactive_bg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_inactive_bg.set", tr1::bind(&ui::Root::set_color_inactive_bg, control->ui(), tr1::placeholders::_2));
-+
-+ CMD2_ANY ("colors.color_dead_fg", tr1::bind(&ui::Root::get_color_dead_fg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_dead_fg.set", tr1::bind(&ui::Root::set_color_dead_fg, control->ui(), tr1::placeholders::_2));
-+ CMD2_ANY ("colors.color_dead_bg", tr1::bind(&ui::Root::get_color_dead_bg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_dead_bg.set", tr1::bind(&ui::Root::set_color_dead_bg, control->ui(), tr1::placeholders::_2));
-+
-+ CMD2_ANY ("colors.color_active_fg", tr1::bind(&ui::Root::get_color_active_fg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_active_fg.set", tr1::bind(&ui::Root::set_color_active_fg, control->ui(), tr1::placeholders::_2));
-+ CMD2_ANY ("colors.color_active_bg", tr1::bind(&ui::Root::get_color_active_bg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_active_bg.set", tr1::bind(&ui::Root::set_color_active_bg, control->ui(), tr1::placeholders::_2));
-+
-+ CMD2_ANY ("colors.color_finished_fg", tr1::bind(&ui::Root::get_color_finished_fg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_finished_fg.set", tr1::bind(&ui::Root::set_color_finished_fg, control->ui(), tr1::placeholders::_2));
-+ CMD2_ANY ("colors.color_finished_bg", tr1::bind(&ui::Root::get_color_finished_bg, control->ui()));
-+ CMD2_ANY_VALUE_V ("colors.color_finished_bg.set", tr1::bind(&ui::Root::set_color_finished_bg, control->ui(), tr1::placeholders::_2));
-+
- // CMD2_ANY_STRING ("encoding_list", tr1::bind(&apply_encoding_list, tr1::placeholders::_2));
- CMD2_ANY_STRING ("encoding.add", tr1::bind(&apply_encoding_list, tr1::placeholders::_2));
+ CMD2_ANY_STRING ("encoding.add", std::bind(&apply_encoding_list, std::placeholders::_2));
-diff --git a/src/display/canvas.cc b/src/display/canvas.cc
-index 31db4ad..255e7c3 100644
---- a/src/display/canvas.cc
-+++ b/src/display/canvas.cc
-@@ -99,6 +99,12 @@ Canvas::initialize() {
- m_isInitialized = true;
++ // Color patch
++ CMD2_ANY ("colors.color_inactive_fg", std::bind(&ui::Root::get_color_inactive_fg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_inactive_fg.set", std::bind(&ui::Root::set_color_inactive_fg, control->ui(), std::placeholders::_2));
++ CMD2_ANY ("colors.color_inactive_bg", std::bind(&ui::Root::get_color_inactive_bg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_inactive_bg.set", std::bind(&ui::Root::set_color_inactive_bg, control->ui(), std::placeholders::_2));
++
++ CMD2_ANY ("colors.color_dead_fg", std::bind(&ui::Root::get_color_dead_fg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_dead_fg.set", std::bind(&ui::Root::set_color_dead_fg, control->ui(), std::placeholders::_2));
++ CMD2_ANY ("colors.color_dead_bg", std::bind(&ui::Root::get_color_dead_bg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_dead_bg.set", std::bind(&ui::Root::set_color_dead_bg, control->ui(), std::placeholders::_2));
++
++ CMD2_ANY ("colors.color_active_fg", std::bind(&ui::Root::get_color_active_fg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_active_fg.set", std::bind(&ui::Root::set_color_active_fg, control->ui(), std::placeholders::_2));
++ CMD2_ANY ("colors.color_active_bg", std::bind(&ui::Root::get_color_active_bg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_active_bg.set", std::bind(&ui::Root::set_color_active_bg, control->ui(), std::placeholders::_2));
++
++ CMD2_ANY ("colors.color_finished_fg", std::bind(&ui::Root::get_color_finished_fg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_finished_fg.set", std::bind(&ui::Root::set_color_finished_fg, control->ui(), std::placeholders::_2));
++ CMD2_ANY ("colors.color_finished_bg", std::bind(&ui::Root::get_color_finished_bg, control->ui()));
++ CMD2_ANY_VALUE_V ("colors.color_finished_bg.set", std::bind(&ui::Root::set_color_finished_bg, control->ui(), std::placeholders::_2));
++
+ // Isn't port_open used?
+ CMD2_VAR_BOOL ("network.port_open", true);
+ CMD2_VAR_BOOL ("network.port_random", true);
+Only in rtorrent-0.9.8_patched/src/core: .deps
+Only in rtorrent-0.9.8/src/core: Makefile.am
+Only in rtorrent-0.9.8/src/core: Makefile.in
+Only in rtorrent-0.9.8_patched/src: .deps
+diff '--color=auto' -ru rtorrent-0.9.8/src/display/canvas.cc rtorrent-0.9.8_patched/src/display/canvas.cc
+--- rtorrent-0.9.8/src/display/canvas.cc 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/display/canvas.cc 2019-07-21 15:42:43.873678687 +0200
+@@ -111,6 +111,12 @@
- initscr();
-+ start_color();
-+ use_default_colors();
-+ init_pair(4, -1, -1);
-+ init_pair(3, -1, -1);
-+ init_pair(2, -1, -1);
-+ init_pair(1, -1, -1);
- raw();
- noecho();
- nodelay(stdscr, TRUE);
-diff --git a/src/display/window_download_list.cc b/src/display/window_download_list.cc
-index ead4ddd..ffd79c9 100644
---- a/src/display/window_download_list.cc
-+++ b/src/display/window_download_list.cc
+ if (!m_isDaemon) {
+ initscr();
++ start_color();
++ use_default_colors();
++ init_pair(4, -1, -1);
++ init_pair(3, -1, -1);
++ init_pair(2, -1, -1);
++ init_pair(1, -1, -1);
+ raw();
+ noecho();
+ nodelay(stdscr, TRUE);
+Only in rtorrent-0.9.8_patched/src/display: .deps
+Only in rtorrent-0.9.8/src/display: Makefile.am
+Only in rtorrent-0.9.8/src/display: Makefile.in
+diff '--color=auto' -ru rtorrent-0.9.8/src/display/window_download_list.cc rtorrent-0.9.8_patched/src/display/window_download_list.cc
+--- rtorrent-0.9.8/src/display/window_download_list.cc 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/display/window_download_list.cc 2019-07-21 15:42:43.873678687 +0200
@@ -37,6 +37,7 @@
#include "config.h"
@@ -58,58 +63,52 @@ index ead4ddd..ffd79c9 100644
#include "core/download.h"
#include "core/view.h"
-@@ -104,9 +105,41 @@ WindowDownloadList::redraw() {
- char buffer[m_canvas->width() + 1];
- char* last = buffer + m_canvas->width() - 2 + 1;
-
-+ /*
-+ There are four states where colors are applied:
-+ 1 inactive # If inactive, e.g. user stopped down/upload
-+ 2 dead # If active but no down/upload
-+ 3 active # If active and download
-+ 4 finished # If finished
-+ */
-+
- print_download_title(buffer, last, *range.first);
-- m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
--
-+ m_canvas->print(0, pos, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
-+ if( (*range.first)->is_done() ) {
-+ if( (*range.first)->download()->info()->up_rate()->rate() != 0 ) {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 4); // Finished and uploading
-+ } else {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 4); // Finished
-+ }
-+ } else if( (*range.first)->is_active() ) {
-+ if( (*range.first)->download()->info()->down_rate()->rate() != 0 ) {
+@@ -135,7 +136,40 @@
+ if (layout_name == "full") {
+ while (range.first != range.second) {
+ print_download_title(buffer, last, *range.first);
+- m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
++
++ /*
++ There are four states where colors are applied:
++ 1 inactive # If inactive, e.g. user stopped down/upload
++ 2 dead # If active but no down/upload
++ 3 active # If active and download
++ 4 finished # If finished
++ */
++ m_canvas->print(0, pos, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
++ if( (*range.first)->is_done() ) {
+ if( (*range.first)->download()->info()->up_rate()->rate() != 0 ) {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 3); // Active and uploading
++ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 4); // Finished and uploading
+ } else {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 3); // Active
++ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 4); // Finished
+ }
-+ } else {
-+ if( (*range.first)->download()->info()->up_rate()->rate() != 0 ) {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 2); // Dead but still uploading
++ } else if( (*range.first)->is_active() ) {
++ if( (*range.first)->download()->info()->down_rate()->rate() != 0 ) {
++ if( (*range.first)->download()->info()->up_rate()->rate() != 0 ) {
++ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 3); // Active and uploading
++ } else {
++ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 3); // Active
++ }
+ } else {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 2); // Dead
++ if( (*range.first)->download()->info()->up_rate()->rate() != 0 ) {
++ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 2); // Dead but still uploading
++ } else {
++ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 2); // Dead
++ }
+ }
++ } else {
++ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 1); // Inactive
+ }
-+ } else {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 1); // Inactive
-+ }
-+ pos++;
++ pos++;
+
- print_download_info(buffer, last, *range.first);
- m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
-
-@@ -114,7 +147,83 @@ WindowDownloadList::redraw() {
- m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+ print_download_info_full(buffer, last, *range.first);
+ m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+ print_download_status(buffer, last, *range.first);
+@@ -155,4 +189,80 @@
+ }
+ }
- ++range.first;
-- }
-+ }
-+}
-+
+// Inactive
+void
+WindowDownloadList::set_color_inactive_fg(int64_t color) {
@@ -184,14 +183,13 @@ index ead4ddd..ffd79c9 100644
+ if( color < 0 ) color = -1;
+ color = color % 8;
+ init_pair(4, fg, (short)color);
++}
++
}
-
- }
-diff --git a/src/display/window_download_list.h b/src/display/window_download_list.h
-index 8e15cac..4551a47 100644
---- a/src/display/window_download_list.h
-+++ b/src/display/window_download_list.h
-@@ -55,6 +55,15 @@ public:
+diff '--color=auto' -ru rtorrent-0.9.8/src/display/window_download_list.h rtorrent-0.9.8_patched/src/display/window_download_list.h
+--- rtorrent-0.9.8/src/display/window_download_list.h 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/display/window_download_list.h 2019-07-21 15:42:43.877012021 +0200
+@@ -55,6 +55,15 @@
void set_view(core::View* l);
@@ -207,11 +205,13 @@ index 8e15cac..4551a47 100644
private:
core::View* m_view;
-diff --git a/src/main.cc b/src/main.cc
-index 5e826bb..44faa21 100644
---- a/src/main.cc
-+++ b/src/main.cc
-@@ -388,6 +388,15 @@ main(int argc, char** argv) {
+Only in rtorrent-0.9.8_patched/src/input: .deps
+Only in rtorrent-0.9.8/src/input: Makefile.am
+Only in rtorrent-0.9.8/src/input: Makefile.in
+diff '--color=auto' -ru rtorrent-0.9.8/src/main.cc rtorrent-0.9.8_patched/src/main.cc
+--- rtorrent-0.9.8/src/main.cc 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/main.cc 2019-07-21 15:42:43.880345353 +0200
+@@ -399,6 +399,15 @@
CMD2_REDIRECT ("ip", "network.local_address.set");
CMD2_REDIRECT ("port_range", "network.port_range.set");
@@ -227,12 +227,17 @@ index 5e826bb..44faa21 100644
CMD2_REDIRECT_GENERIC("dht", "dht.mode.set");
CMD2_REDIRECT_GENERIC("dht_port", "dht.port.set");
-diff --git a/src/ui/download_list.cc b/src/ui/download_list.cc
-index e3abc9a..7dc7469 100644
---- a/src/ui/download_list.cc
-+++ b/src/ui/download_list.cc
-@@ -136,6 +136,11 @@ DownloadList::unfocus_download(core::Download* d) {
- current_view()->next_focus();
+Only in rtorrent-0.9.8/src: Makefile.am
+Only in rtorrent-0.9.8/src: Makefile.in
+Only in rtorrent-0.9.8_patched/src/rpc: .deps
+Only in rtorrent-0.9.8/src/rpc: Makefile.am
+Only in rtorrent-0.9.8/src/rpc: Makefile.in
+Only in rtorrent-0.9.8_patched/src/ui: .deps
+diff '--color=auto' -ru rtorrent-0.9.8/src/ui/download_list.cc rtorrent-0.9.8_patched/src/ui/download_list.cc
+--- rtorrent-0.9.8/src/ui/download_list.cc 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/ui/download_list.cc 2019-07-21 15:42:43.863678687 +0200
+@@ -135,6 +135,11 @@
+ current_view()->next_focus();
}
+display::WindowDownloadList*
@@ -243,11 +248,10 @@ index e3abc9a..7dc7469 100644
void
DownloadList::activate_display(Display displayType) {
if (!is_active())
-diff --git a/src/ui/download_list.h b/src/ui/download_list.h
-index 3712e36..7810f65 100644
---- a/src/ui/download_list.h
-+++ b/src/ui/download_list.h
-@@ -98,6 +98,7 @@ public:
+diff '--color=auto' -ru rtorrent-0.9.8/src/ui/download_list.h rtorrent-0.9.8_patched/src/ui/download_list.h
+--- rtorrent-0.9.8/src/ui/download_list.h 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/ui/download_list.h 2019-07-21 15:42:43.863678687 +0200
+@@ -100,6 +100,7 @@
void activate_display(Display d);
core::View* current_view();
@@ -255,11 +259,10 @@ index 3712e36..7810f65 100644
void set_current_view(const std::string& name);
void slot_open_uri(slot_string s) { m_slot_open_uri = s; }
-diff --git a/src/ui/element_download_list.h b/src/ui/element_download_list.h
-index 20185b5..00ef880 100644
---- a/src/ui/element_download_list.h
-+++ b/src/ui/element_download_list.h
-@@ -60,6 +60,7 @@ public:
+diff '--color=auto' -ru rtorrent-0.9.8/src/ui/element_download_list.h rtorrent-0.9.8_patched/src/ui/element_download_list.h
+--- rtorrent-0.9.8/src/ui/element_download_list.h 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/ui/element_download_list.h 2019-07-21 15:42:43.863678687 +0200
+@@ -60,6 +60,7 @@
void disable();
core::View* view() { return m_view; }
@@ -267,11 +270,12 @@ index 20185b5..00ef880 100644
void set_view(core::View* l);
void receive_command(const char* cmd);
-diff --git a/src/ui/root.cc b/src/ui/root.cc
-index 981fcc2..2df0f5a 100644
---- a/src/ui/root.cc
-+++ b/src/ui/root.cc
-@@ -44,6 +44,7 @@
+Only in rtorrent-0.9.8/src/ui: Makefile.am
+Only in rtorrent-0.9.8/src/ui: Makefile.in
+diff '--color=auto' -ru rtorrent-0.9.8/src/ui/root.cc rtorrent-0.9.8_patched/src/ui/root.cc
+--- rtorrent-0.9.8/src/ui/root.cc 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/ui/root.cc 2019-07-21 15:42:43.863678687 +0200
+@@ -47,6 +47,7 @@
#include "core/manager.h"
#include "display/frame.h"
@@ -279,12 +283,10 @@ index 981fcc2..2df0f5a 100644
#include "display/window_http_queue.h"
#include "display/window_title.h"
#include "display/window_input.h"
-@@ -65,7 +66,15 @@ Root::Root() :
- m_windowTitle(NULL),
+@@ -70,6 +71,14 @@
m_windowHttpQueue(NULL),
m_windowInput(NULL),
-- m_windowStatusbar(NULL) {
-+ m_windowStatusbar(NULL),
+ m_windowStatusbar(NULL),
+ color_inactive_fg(-1),
+ color_inactive_bg(-1),
+ color_dead_fg(-1),
@@ -292,11 +294,11 @@ index 981fcc2..2df0f5a 100644
+ color_active_fg(-1),
+ color_active_bg(-1),
+ color_finished_fg(-1),
-+ color_finished_bg(-1) {
- }
-
- void
-@@ -97,6 +106,14 @@ Root::init(Control* c) {
++ color_finished_bg(-1),
+ m_input_history_length(99),
+ m_input_history_last_input(""),
+ m_input_history_pointer_get(0) {
+@@ -111,6 +120,14 @@
setup_keys();
m_downloadList->activate(rootFrame->frame(1));
@@ -311,8 +313,8 @@ index 981fcc2..2df0f5a 100644
}
void
-@@ -272,4 +289,88 @@ Root::current_input() {
- return m_windowInput->input();
+@@ -504,4 +521,88 @@
+ }
}
+// Inactive
@@ -400,11 +402,10 @@ index 981fcc2..2df0f5a 100644
+}
+
}
-diff --git a/src/ui/root.h b/src/ui/root.h
-index cbc5ff4..a550aeb 100644
---- a/src/ui/root.h
-+++ b/src/ui/root.h
-@@ -83,6 +83,23 @@ public:
+diff '--color=auto' -ru rtorrent-0.9.8/src/ui/root.h rtorrent-0.9.8_patched/src/ui/root.h
+--- rtorrent-0.9.8/src/ui/root.h 2019-07-19 13:43:13.000000000 +0200
++++ rtorrent-0.9.8_patched/src/ui/root.h 2019-07-21 15:42:43.860345355 +0200
+@@ -88,6 +88,23 @@
void set_down_throttle_i64(int64_t throttle) { set_down_throttle(throttle >> 10); }
void set_up_throttle_i64(int64_t throttle) { set_up_throttle(throttle >> 10); }
@@ -428,11 +429,10 @@ index cbc5ff4..a550aeb 100644
void adjust_down_throttle(int throttle);
void adjust_up_throttle(int throttle);
-@@ -105,6 +122,15 @@ private:
- WStatusbar* m_windowStatusbar;
+@@ -119,6 +136,15 @@
input::Bindings m_bindings;
-+
+
+ int64_t color_inactive_fg;
+ int64_t color_inactive_bg;
+ int64_t color_dead_fg;
@@ -441,6 +441,16 @@ index cbc5ff4..a550aeb 100644
+ int64_t color_active_bg;
+ int64_t color_finished_fg;
+ int64_t color_finished_bg;
- };
-
- }
++
+ int m_input_history_length;
+ std::string m_input_history_last_input;
+ int m_input_history_pointer_get;
+Only in rtorrent-0.9.8_patched/src/utils: .deps
+Only in rtorrent-0.9.8/src/utils: Makefile.am
+Only in rtorrent-0.9.8/src/utils: Makefile.in
+Only in rtorrent-0.9.8_patched: stamp-h1
+Only in rtorrent-0.9.8_patched/test: .deps
+Only in rtorrent-0.9.8/test: Makefile.am
+Only in rtorrent-0.9.8/test: Makefile.in
+Only in rtorrent-0.9.8_patched/test/rpc: .deps
+Only in rtorrent-0.9.8_patched/test/src: .deps