summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwcasanova2021-06-27 12:33:35 -0300
committerwcasanova2021-06-27 12:33:35 -0300
commit04b7b7ce941c344f11ea0864f3006b139b9fceef (patch)
treec7ce7932511b98737b8590ae90d8c363139f53b7
parentf4baf5730b3ffcb1ba32a9055eaf190d053c213c (diff)
downloadaur-rua-git.tar.gz
update, remove git
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD39
2 files changed, 16 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3de7d9786f1..5be3f7d8369f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rua-git
pkgdesc = Build tool for Arch Linux providing control, review and jailed build options
- pkgver = 0.15.2.351.g9900bc2
+ pkgver = 0.18.1.498.ge0e253f
pkgrel = 1
url = https://github.com/vn971/rua
arch = i686
@@ -21,4 +21,3 @@ pkgbase = rua-git
sha256sums = SKIP
pkgname = rua-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 467268f16061..77a235f871dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Walter C <bitlord {at} disroot {dot} org>
-# Maintainer: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
+# Maintainer: Walter - "bWVAd2FsdGVyY2FzYW5vdmEueHljCg==" - base64
+# Contributor: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
pkgname="rua-git"
_pkgname="rua"
-pkgver=0.15.2.351.g9900bc2
+pkgver=0.18.1.498.ge0e253f
pkgrel=1
pkgdesc="Build tool for Arch Linux providing control, review and jailed build options"
arch=("i686" "x86_64")
@@ -21,30 +21,21 @@ source=("$_pkgname::git+https://github.com/vn971/rua.git")
sha256sums=("SKIP")
pkgver() {
- cd "$_pkgname"
- echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+ cd "$_pkgname"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
-build () {
- cd $_pkgname
- mkdir -p target/completions
-
- if pacman -T pacman-git > /dev/null; then
- _features="git"
- fi
- COMPLETIONS_DIR=target/completions \
- cargo build --features "${_features:-}" --release --locked
-}
-
-check() {
- cd $_pkgname
- cargo test --release --locked
+build() {
+ cd "$_pkgname"
+ mkdir -p target/completions
+ COMPLETIONS_DIR=target/completions \
+ RUSTUP_TOOLCHAIN=stable cargo build --release --locked --all-features --target-dir=target
}
package() {
- cd "$srcdir/$_pkgname"
- install -Dm755 target/release/$_pkgname "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 target/completions/rua.bash "${pkgdir}/usr/share/bash-completion/completions/rua.bash"
- install -Dm644 target/completions/rua.fish "${pkgdir}/usr/share/fish/completions/rua.fish"
- install -Dm644 target/completions/_rua "${pkgdir}/usr/share/zsh/functions/Completion/Linux/_rua"
+ cd "$srcdir/$_pkgname"
+ install -Dm755 target/release/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 target/completions/rua.bash "${pkgdir}/usr/share/bash-completion/completions/rua.bash"
+ install -Dm644 target/completions/rua.fish "${pkgdir}/usr/share/fish/completions/rua.fish"
+ install -Dm644 target/completions/_rua "${pkgdir}/usr/share/zsh/functions/Completion/Linux/_rua"
}