summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-06-25 15:17:41 +0200
committerwillemw122021-06-25 15:17:41 +0200
commite51ba44cddfaca7c3a0cf8865aa3ecf140dc2df9 (patch)
treeb1258e29f550f102b5f12400aa286ae8e01e06ea
parentaecf458a621648d853b7f6987c1a8107834d2d7d (diff)
downloadaur-rubix.tar.gz
Remove arch
Remove cd.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a22880fa335..a824f95cae4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,13 +2,11 @@ pkgbase = rubix
pkgdesc = Rubik's cube program
pkgver = 1.0.6
pkgrel = 3
- url = http://sed.free.fr/rubix/
- arch = i686
+ url = http://sed.free.fr/rubix
arch = x86_64
license = custom:Public Domain
depends = libx11
source = http://sed.free.fr/rubix/rubix-1.0.6.tar.bz2
- md5sums = 76346b49b67dd7ade0f69b4ae77e3f3a
+ sha256sums = ccff4c98373f76c6bab751f5f5a60df7ad8691c79b56157e4aba2dd76f501a87
pkgname = rubix
-
diff --git a/PKGBUILD b/PKGBUILD
index 21d14d4ed5ee..f0c9083ea0c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,18 @@ pkgname=rubix
pkgver=1.0.6
pkgrel=3
pkgdesc="Rubik's cube program"
-arch=('i686' 'x86_64')
-url="http://sed.free.fr/rubix/"
+arch=('x86_64')
+url="http://sed.free.fr/rubix"
license=('custom:Public Domain')
depends=('libx11')
-source=("http://sed.free.fr/rubix/$pkgname-$pkgver.tar.bz2")
-md5sums=("76346b49b67dd7ade0f69b4ae77e3f3a")
+source=($url/$pkgname-$pkgver.tar.bz2)
+sha256sums=('ccff4c98373f76c6bab751f5f5a60df7ad8691c79b56157e4aba2dd76f501a87')
build() {
- cd $pkgname-$pkgver
- make
+ make -C $pkgname-$pkgver
}
package() {
- cd $pkgname-$pkgver
- install -Dm755 rubix "$pkgdir/usr/bin/rubix"
+ install -Dm755 $pkgname-$pkgver/rubix "$pkgdir/usr/bin/rubix"
}