summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-11-19 02:29:09 +0100
committerMichael Straube2016-11-19 02:29:09 +0100
commit26735b9ca84b5efc6e8bc13465364751c4e2943f (patch)
tree9c278c97775ab4b39412198bc48354476102e9e7
parent31351b184a03e20f571aa27034701f91f594f332 (diff)
downloadaur-ruby-artii.tar.gz
Update to 2.1.2
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD17
3 files changed, 38 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5aa2b1cb2167..38b44b360223 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ruby-artii
pkgdesc = A Figlet-based ASCII art generator, useful for comand-line based ASCII Art Generation
- pkgver = 2.1.1
+ pkgver = 2.1.2
pkgrel = 1
url = https://github.com/miketierney/artii
arch = any
@@ -9,9 +9,11 @@ pkgbase = ruby-artii
provides = artii
provides = ruby-artii
conflicts = artii
- noextract = artii-2.1.1.gem
- source = https://rubygems.org/downloads/artii-2.1.1.gem
- sha256sums = 9b683c36f0eb5aa8c02c767d00cd7e70de1b84ff50396b47dc098789ec465861
+ noextract = artii-2.1.2.gem
+ source = https://rubygems.org/downloads/artii-2.1.2.gem
+ source = LICENSE
+ sha256sums = 15410369690634fccf801fd95ae9762c3b2b7254e17a07e77a069e5cd292bc49
+ sha256sums = 8b943160ff00be00386b1049f928fe846af996f5cc09950ffbfb5888a95a4320
pkgname = ruby-artii
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6638b7805938
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+(The MIT License)
+
+Copyright © 2016 Michael Tierney
+
+miketierney.com
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the 'Software'), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so,subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED 'AS IS', WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 99add53aa1c9..a47769be0bdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=ruby-artii
-pkgver=2.1.1
+pkgver=2.1.2
pkgrel=1
pkgdesc="A Figlet-based ASCII art generator, useful for comand-line based ASCII Art Generation"
arch=('any')
-depends=('ruby')
url="https://github.com/miketierney/artii"
license=('MIT')
-source=(https://rubygems.org/downloads/${pkgname#*-}-${pkgver}.gem)
-sha256sums=('9b683c36f0eb5aa8c02c767d00cd7e70de1b84ff50396b47dc098789ec465861')
-noextract=("${pkgname#*-}-${pkgver}.gem")
+depends=('ruby')
provides=('artii' 'ruby-artii')
conflicts=('artii')
+source=("https://rubygems.org/downloads/${pkgname#*-}-${pkgver}.gem"
+ "LICENSE")
+noextract=("${pkgname#*-}-${pkgver}.gem")
+sha256sums=('15410369690634fccf801fd95ae9762c3b2b7254e17a07e77a069e5cd292bc49'
+ '8b943160ff00be00386b1049f928fe846af996f5cc09950ffbfb5888a95a4320')
package() {
- cd "$srcdir"
-
- msg 'Installing...'
gem install \
--no-user-install \
--ignore-dependencies \
-i "$pkgdir$(ruby -rubygems -e'puts Gem.default_dir')" \
${pkgname#*-}-$pkgver.gem
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}