summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:38:02 -0300
committerBruno Galeotti2015-06-08 15:38:02 -0300
commit187d971f71092504e31d02e90da08c76010b7621 (patch)
tree2571b613f256ded36bd9f924f930d3110bbef3e1
downloadaur-ruby-capistrano-rsync-with-remote-cache.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e799033e5f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-capistrano-rsync-with-remote-cache
+ pkgdesc = A deployment strategy for Capistrano 2.0 which combines rsync with a remote cache, allowing fast deployments from SCM servers behind firewalls.
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = http://www.viget.com/extend/
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = rubygems
+ depends = ruby-capistrano
+ noextract = capistrano_rsync_with_remote_cache-2.4.0.gem
+ source = http://rubygems.org/downloads/capistrano_rsync_with_remote_cache-2.4.0.gem
+ md5sums = 6b65eead662a7e825a7dc6f6bbfd389c
+
+pkgname = ruby-capistrano-rsync-with-remote-cache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5360678202b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Bruno Galeotti <bgaleotti at gmail dot com>
+pkgname=ruby-capistrano-rsync-with-remote-cache
+_gemname=capistrano_rsync_with_remote_cache
+pkgver=2.4.0
+pkgrel=1
+pkgdesc='A deployment strategy for Capistrano 2.0 which combines rsync with a remote cache, allowing fast deployments from SCM servers behind firewalls.'
+arch=('any')
+url='http://www.viget.com/extend/'
+license=('MIT')
+depends=('ruby' 'rubygems' 'ruby-capistrano')
+source=(http://rubygems.org/downloads/${_gemname}-${pkgver}.gem)
+noextract=(${_gemname}-${pkgver}.gem)
+md5sums=('6b65eead662a7e825a7dc6f6bbfd389c')
+
+build() {
+ cd "${srcdir}"
+ export HOME=/tmp
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --no-user-install --ignore-dependencies -i "${pkgdir}${_gemdir}" ${_gemname}-${pkgver}.gem
+}