summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkulpae2015-11-02 21:56:10 +0100
committerkulpae2015-11-02 21:56:10 +0100
commitbf50e1d9ccccadd4558a6a5762b35fb418b8935a (patch)
treed2addb29f9aed656470051fd61860f2af146161a
downloadaur-ruby-gobject-introspection-3.0.7.tar.gz
fixed version of gobject-introspection (3.0.7)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc046e8dd372
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ruby-gobject-introspection-3.0.7
+ pkgdesc = Ruby/GObjectIntrospection is a Ruby binding of GObjectIntrospection.
+ pkgver = 3.0.7
+ pkgrel = 1
+ url = http://ruby-gnome2.sourceforge.jp/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = ruby
+ depends = ruby-glib2-3.0.7
+ depends = gobject-introspection-runtime
+ noextract = gobject-introspection-3.0.7.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/gobject-introspection-3.0.7.gem
+ sha1sums = 794c81a17474e297793bb9a1ecff0e1cde6ea6fb
+
+pkgname = ruby-gobject-introspection-3.0.7
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..138a7d94a8f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: kulpae <my.shando@googlemail.com>
+
+_gemname=gobject-introspection
+pkgname=ruby-$_gemname-3.0.7
+pkgver=3.0.7
+pkgrel=1
+pkgdesc='Ruby/GObjectIntrospection is a Ruby binding of GObjectIntrospection.'
+arch=(i686 x86_64)
+url='http://ruby-gnome2.sourceforge.jp/'
+license=('LGPL2.1')
+depends=(ruby ruby-glib2-3.0.7 gobject-introspection-runtime)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('794c81a17474e297793bb9a1ecff0e1cde6ea6fb')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}