summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjorn Neergaard2015-06-09 08:32:16 -0700
committerBjorn Neergaard2015-06-09 08:32:16 -0700
commit7c09fb62ebb0a579dc1b0090781e1ab767a35520 (patch)
treeab1a51edd3d29bd505d32a90075b1e869a6f3962
downloadaur-ruby-haste-git.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc7521cd510f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-haste-git
+ pkgdesc = Simple client for uploading text to a haste-server (hastebin) (development version)
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/seejohnrun/haste-client
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = ruby
+ depends = ruby-json
+ provides = ruby-haste
+ conflicts = ruby-haste
+ source = ruby-haste::git+https://github.com/seejohnrun/haste-client.git
+ sha256sums = SKIP
+
+pkgname = ruby-haste-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db1d32f47cf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
+# Contributor: Matt Harrison <matt@mistbyte.com>
+
+_pkgname=ruby-haste
+pkgname=ruby-haste-git
+pkgver=latest
+pkgrel=1
+pkgdesc='Simple client for uploading text to a haste-server (hastebin) (development version)'
+url='https://github.com/seejohnrun/haste-client'
+license=('MIT')
+source=("${_pkgname}::git+https://github.com/seejohnrun/haste-client.git")
+sha256sums=('SKIP')
+arch=('any')
+depends=('ruby' 'ruby-json')
+makedepends=('git')
+conflicts=('ruby-haste')
+provides=('ruby-haste')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Build it!
+ gem build haste.gemspec
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Install the program.
+ gem install --no-user-install --ignore-dependencies \
+ -i "${pkgdir}$(ruby -e 'puts Gem.default_dir')" \
+ -n "${pkgdir}/usr/bin" \
+ haste-*.gem
+}
+
+# vim: ft=sh ts=2 sw=2 et