summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-12-27 21:11:13 -0500
committerMario Finelli2016-12-27 21:11:13 -0500
commit4924f7c92c20319b78a5fa90b3e3c246bc5b6f9a (patch)
tree539cafd6e544962038fceb43c99d59294a7ba447
downloadaur-ruby-http_router.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ea462581065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Dec 28 02:11:05 UTC 2016
+pkgbase = ruby-http_router
+ pkgdesc = This library allows you to recognize and build URLs in a Rack application.
+ pkgver = 0.11.2
+ pkgrel = 1
+ url = https://github.com/joshbuddy/http_router
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-rack
+ depends = ruby-url_mount
+ noextract = http_router-0.11.2.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/http_router-0.11.2.gem
+ sha256sums = bffe3cf2fa05191d47225d4901893cff2990e3c5d813ebfd388762a0905d2c5a
+
+pkgname = ruby-http_router
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddcdb9bed46e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_gemname=http_router
+pkgname=ruby-$_gemname
+pkgver=0.11.2
+pkgrel=1
+pkgdesc='This library allows you to recognize and build URLs in a Rack application.'
+arch=(any)
+url='https://github.com/joshbuddy/http_router'
+license=(MIT)
+depends=(ruby ruby-rack ruby-url_mount)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('bffe3cf2fa05191d47225d4901893cff2990e3c5d813ebfd388762a0905d2c5a')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}