summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2015-11-25 10:40:58 +0100
committerCarsten Feuls2015-11-25 10:40:58 +0100
commitd2fbe07c1793a202d8ffe4bd98807d996f3ca442 (patch)
tree453251d507d7abd5ecd9a9ed10bf71e890e31b27
downloadaur-ruby-popen4.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb8cdb2c6a72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-popen4
+ pkgdesc = A single API across platforms for executing a command in a child process.
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/shairontoledo/popen4/
+ arch = any
+ license = RUBY
+ depends = ruby
+ depends = rubygems
+ depends = ruby-open4
+ depends = ruby-platform
+ noextract = popen4-0.1.2.gem
+ source = http://rubygems.org/downloads/popen4-0.1.2.gem
+ sha512sums = d97524f1c3792c5f922fd5b335dcfcc0f5320496e035458e73307e81480470df49ccbe2b5c80820c2ef7b2b47612bc145e408301458ab4426e1a03daa21d8bd0
+
+pkgname = ruby-popen4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e82a1bc1e30e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+
+pkgname=ruby-popen4
+_gemname=${pkgname#ruby-}
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A single API across platforms for executing a command in a child process."
+arch=('any')
+url="https://github.com/shairontoledo/popen4/"
+license=('RUBY')
+depends=('ruby' 'rubygems' 'ruby-open4' 'ruby-platform')
+source=(http://rubygems.org/downloads/${_gemname}-${pkgver}.gem)
+noextract=(${_gemname}-${pkgver}.gem)
+
+package() {
+ cd "${srcdir}"
+ export HOME=/tmp
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --no-user-install --ignore-dependencies \
+ -i "${pkgdir}${_gemdir}" -n "${pkgdir}/usr/bin" ${_gemname}-${pkgver}.gem
+}
+sha512sums=('d97524f1c3792c5f922fd5b335dcfcc0f5320496e035458e73307e81480470df49ccbe2b5c80820c2ef7b2b47612bc145e408301458ab4426e1a03daa21d8bd0')