summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2023-12-02 12:50:00 +0100
committerHenry-Joseph Audéoud2023-12-02 12:50:00 +0100
commiteb2eb2eec028c1a4ac9e877c7a2f2f99b66b5239 (patch)
tree0f4e601b24782e87136887c4fc72ce54b55d1d0d
downloadaur-ruby-unicode-scripts.tar.gz
Initial upload: ruby-differ 0.1.2-1
Initial upload: ruby-unicode-blocks 1.9.0-1 Initial upload: ruby-unicode-name 1.12.0-1 Initial upload: ruby-unicode-scripts 1.9.0-1 Initial upload: ruby-unicode-types 1.9.0-1 upgpkg: ruby-kramdown-rfc2629 1.7.3-1 upstream release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..469fa593e438
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ruby-unicode-scripts
+ pkgdesc = [Unicode 15.1.0] Retrieve the Unicode script(s) a string belongs to. Can also return the Script_Extension property which is defined as characters which are 'commonly used with more than one script, but with a limited number of scripts'.
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = https://github.com/janlelis/unicode-scripts
+ arch = any
+ license = MIT
+ depends = ruby
+ noextract = unicode-scripts-1.9.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/unicode-scripts-1.9.0.gem
+ sha256sums = b9c9fbaf405b67f9fa3bbadcc66bbb539f5148c9b11126c23038655bb4665d54
+
+pkgname = ruby-unicode-scripts
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59ad2edaecb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Henry-Joseph Audéoud <h.audeoud+aur@gmail.com>
+
+pkgname=ruby-unicode-scripts
+_name="${pkgname#ruby-}"
+pkgver=1.9.0
+pkgrel=1
+pkgdesc='[Unicode 15.1.0] Retrieve the Unicode script(s) a string belongs to. Can also return the Script_Extension property which is defined as characters which are '"'"'commonly used with more than one script, but with a limited number of scripts'"'"'. '
+arch=(any)
+url="https://github.com/janlelis/${_name}"
+license=('MIT')
+depends=(ruby)
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${_name}-${pkgver}.gem")
+noextract=("${_name}-${pkgver}.gem")
+sha256sums=(b9c9fbaf405b67f9fa3bbadcc66bbb539f5148c9b11126c23038655bb4665d54)
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install \
+ -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "${_name}-${pkgver}.gem"
+
+ install -D -m644 "${pkgdir}/${_gemdir}/gems/${_name}-${pkgver}/MIT-LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}