summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBertrand Bonnefoy-Claudet2022-05-06 10:21:05 +0200
committerBertrand Bonnefoy-Claudet2022-05-06 10:21:05 +0200
commitef5e7be80ee3ab48b46d37471780bf8ed5842c06 (patch)
tree038f9f56fd6b5daead293db8187f8336c279bb60
parent31f5f3ef176bb0c6c0549457dc847e408399e4af (diff)
downloadaur-ruby-veewee.tar.gz
Fix package dependencies
- Remove redundant dependency on `ruby-ruby-vnc>=1.0.0' since we already depend on `ruby-ruby-vnc-1.0`. - Depend on `ruby-thor-0.20` instead of `ruby-thor>=0.15`. I haven't checked if the recent versions of `ruby-thor` have problematic breaking changes but this was recommended by a user.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 302076273875..a3215c8d40e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ruby-veewee
pkgdesc = A tool for building custom Vagrant base boxes and virtual machine images.
pkgver = 0.4.5.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jedi4ever/veewee
arch = any
license = MIT
@@ -20,8 +20,7 @@ pkgbase = ruby-veewee
depends = ruby-popen4>=0.1.2
depends = ruby-progressbar
depends = ruby-ruby-vnc-1.0
- depends = ruby-ruby-vnc>=1.0.0
- depends = ruby-thor>=0.15
+ depends = ruby-thor-0.20
depends = ruby-to_slug
provides = veewee
conflicts = veewee
diff --git a/PKGBUILD b/PKGBUILD
index 4447b843f9ee..994f895c4e6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,15 @@
_gemname=veewee
pkgname=ruby-$_gemname
pkgver=0.4.5.1
-pkgrel=2
+pkgrel=3
pkgdesc="A tool for building custom Vagrant base boxes and virtual machine images."
arch=(any)
url="https://github.com/jedi4ever/veewee"
license=('MIT')
-depends=('ruby' 'ruby-ansi-1.3' 'ruby-childprocess'
- 'ruby-fission' 'ruby-fog>=1.8' 'ruby-grit' 'ruby-highline'
- 'ruby-json' 'ruby-mime-types-1>=1.16' 'ruby-i18n'
- 'ruby-net-ssh>=2.2.0' 'ruby-os>=0.9.6' 'ruby-popen4>=0.1.2'
- 'ruby-progressbar' 'ruby-ruby-vnc-1.0' 'ruby-ruby-vnc>=1.0.0'
- 'ruby-thor>=0.15' 'ruby-to_slug')
+depends=('ruby' 'ruby-ansi-1.3' 'ruby-childprocess' 'ruby-fission' 'ruby-fog>=1.8'
+ 'ruby-grit' 'ruby-highline' 'ruby-json' 'ruby-mime-types-1>=1.16' 'ruby-i18n'
+ 'ruby-net-ssh>=2.2.0' 'ruby-os>=0.9.6' 'ruby-popen4>=0.1.2' 'ruby-progressbar'
+ 'ruby-ruby-vnc-1.0' 'ruby-thor-0.20' 'ruby-to_slug')
provides=('veewee')
conflicts=('veewee')
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)