summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Weber2021-09-24 00:37:44 -0600
committerMax Weber2021-09-24 00:37:44 -0600
commitab89c36aa9ce3923e3acb19ae74380076e27e251 (patch)
tree865ad8206d7868c1b2228f2333a978e8f8ee3510
parente5e57d4cd7bbd2d50e80d7630dfdc96e24715693 (diff)
downloadaur-ab89c36aa9ce3923e3acb19ae74380076e27e251.tar.gz
use a unique srcdir name for license
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index ba4d79feb7d5..be9792987fd8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@ src/
*.tar*
RuneLite.jar
runelite.png
-LICENSE \ No newline at end of file
+LICENSE
+*.LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 8ad6c589b38a..d4577a463ac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ optdepends=(
'libnotify: native tray notifications')
makedepends=()
source=("https://github.com/runelite/launcher/releases/download/${pkgver}/RuneLite.jar"
- "https://raw.githubusercontent.com/runelite/launcher/${pkgver}/LICENSE"
+ "RuneLite.LICENSE::https://raw.githubusercontent.com/runelite/launcher/${pkgver}/LICENSE"
"https://raw.githubusercontent.com/runelite/launcher/${pkgver}/appimage/runelite.png"
runelite.desktop)
noextract=('RuneLite.jar')
@@ -40,7 +40,7 @@ package() {
"${pkgdir}/usr/share/pixmaps/runelite.png"
install -D -m644 \
- "${srcdir}/LICENSE" \
+ "${srcdir}/RuneLite.LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m755 \