summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordroserasprout2021-02-18 19:53:14 +0300
committerdroserasprout2021-02-18 19:53:14 +0300
commit51930e0bf25cb2639a1a52cbea2d6d4dbab32ed7 (patch)
tree18e0e98e0e85665fb0d6265a568ba7d16917aab0
downloadaur-runice-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37251ca82973
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = runice-git
+ pkgdesc = A daemon to manage process niceness, written in Rust
+ pkgver = r20.b3127a3
+ pkgrel = 1
+ url = https://github.com/droserasprout/runice
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ depends = schedtool
+ depends = util-linux
+ provides = runice
+ source = git+https://github.com/droserasprout/runice#branch=master
+ sha512sums = SKIP
+
+pkgname = runice-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dda87d3396b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=runice-git
+_pkgname=runice
+pkgver=r20.b3127a3
+pkgrel=1
+pkgdesc="A daemon to manage process niceness, written in Rust"
+url="https://github.com/droserasprout/runice"
+arch=(x86_64)
+license=(MIT)
+provides=(runice)
+depends=(schedtool util-linux)
+makedepends=(cargo git)
+source=("git+https://github.com/droserasprout/runice#branch=master")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ cargo fetch --locked --target x86_64-unknown-linux-gnu
+}
+
+build() {
+ cd $_pkgname
+ cargo build --release --frozen --all-targets
+}
+
+check() {
+ cd $_pkgname
+ # test_expand* fails; needs nightly rust
+ cargo test --release --frozen || :
+}
+
+package() {
+ cd $_pkgname
+ install -Dt "$pkgdir/usr/bin" target/release/runice
+ install -d "$pkgdir/etc/runice/00-ananicy" config/00-ananicy/
+ install -d "$pkgdir/etc/runice/10-default" config/10-default/
+ install config/10-default/* "$pkgdir/etc/runice/10-default"
+ install -d "$pkgdir/etc/runice/20-local" config/20-local/
+ install -Dt "$pkgdir/usr/lib/systemd/system" runice.service
+} \ No newline at end of file