summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry782019-01-18 23:15:11 +0100
committerHenry782019-01-18 23:15:11 +0100
commit107fdad55ee08bb6119f848c17a411fafeb4c770 (patch)
tree8ceee638d9761210e9658d3949566f39f1002d95
downloadaur-107fdad55ee08bb6119f848c17a411fafeb4c770.tar.gz
initial package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a787c935fb85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = runrestic
+ pkgdesc = A wrapper script for Restic backup software that inits, creates, prunes and checks backups
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = https://github.com/andreasnuesslein/runrestic
+ arch = any
+ license = GPL3
+ depends = python
+ source = https://github.com/andreasnuesslein/runrestic/archive/0.2.8.tar.gz
+ md5sums = 5334faa77135db50407511552cb197fa
+
+pkgname = runrestic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0084f422e831
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Henry78 <henry78@gmx.at>
+pkgname=runrestic
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="A wrapper script for Restic backup software that inits, creates, prunes and checks backups"
+arch=(any)
+url="https://github.com/andreasnuesslein/runrestic"
+license=("GPL3")
+depends=("python")
+source=("https://github.com/andreasnuesslein/runrestic/archive/0.2.8.tar.gz")
+md5sums=('5334faa77135db50407511552cb197fa')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python3 setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ sed -i 's%/usr/local%/usr%' sample/systemd/runrestic.service
+ install -Dm644 sample/systemd/runrestic.service ${pkgdir}/usr/lib/systemd/system/runrestic.service
+ install -Dm644 sample/systemd/runrestic.timer ${pkgdir}/usr/lib/systemd/system/runrestic.timer
+}