summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Chevalier2017-03-08 09:06:14 +0000
committerPierre Chevalier2017-03-08 09:06:14 +0000
commit420fa71853d1aed6d54a61d2129b12b337499a36 (patch)
tree729bb198d0da4b6e90ad55acf14b024be458aea4
downloadaur-420fa71853d1aed6d54a61d2129b12b337499a36.tar.gz
Upload rust-dwm-status version 0.1.0 to the aur
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bed07b415e55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rust-dwm-status
+ pkgdesc = A status bar for tiling window managers with pretty unicode symbols written in rust
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/pierrechevalier83/rust-dwm-status
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = xorg-xsetroot
+ source = rust-dwm-status-0.1.0.tar.gz::https://crates.io/api/v1/crates/rust-dwm-status/0.1.0/download
+ sha256sums = 579dafb5f4c0de8a8c6e17f94bf7fc6cc9be6e6fa4960b3efc0c22ccca56ed21
+
+pkgname = rust-dwm-status
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e02999660d44
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+rust-dwm-status*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09a5b0c5d93a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Maintainer: Pierre Chevalier <pierrechevalier83@gmail.com>
+
+pkgname=rust-dwm-status
+_pkgname=rust-dwm-status
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A status bar for tiling window managers with pretty unicode symbols written in rust"
+url="https://github.com/pierrechevalier83/rust-dwm-status"
+makedepends=('cargo')
+depends=('xorg-xsetroot')
+arch=('i686' 'x86_64')
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://crates.io/api/v1/crates/$_pkgname/$pkgver/download")
+sha256sums=('579dafb5f4c0de8a8c6e17f94bf7fc6cc9be6e6fa4960b3efc0c22ccca56ed21')
+build() {
+ cd "$_pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -Dm755 target/release/rust-dwm-status "$pkgdir/usr/bin/rust-dwm-status"
+}