summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2021-01-09 15:06:38 +0000
committerGreyson Christoforo2021-01-09 15:06:38 +0000
commit3efed2b008d072aebe965cfb933d72658d39e1ed (patch)
treea0a326f02f91295a90575b579bd8dfe4f2b97711
parentc62703c2114def9d7c2e6188f0b9e2b521c94076 (diff)
downloadaur-rust-wasm.tar.gz
fix cache dir
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a8d85aadeee..09c04e0b82a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,11 +53,13 @@ END
build() {
cd "rustc-$pkgver-src"
+ export CARGO_HOME="${srcdir}/cargo_home"
python x.py dist -j "$(nproc)"
}
package() {
cd "rustc-$pkgver-src"
+ export CARGO_HOME="${srcdir}/cargo_home"
DESTDIR="${pkgdir}" python x.py install -j "$(nproc)"
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE*