summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Recloux2021-03-25 08:19:57 +0100
committerThomas Recloux2021-03-25 08:19:57 +0100
commitba0f9ae3ffde427fb11433f99a98a5a08706035d (patch)
tree8871caca02afb244fdb8ae1dfe16614a56bb7f4e
downloadaur-rustic.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb70560b8ec6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rustic
+ pkgdesc = Rustic is a wrapper around the Restic backup program
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/bnavetta/rustic
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = rust
+ makedepends = git
+ depends = restic
+ provides = rustic
+ conflicts = rustic
+ source = git+https://github.com/bnavetta/rustic#tag=v0.2.1
+ sha256sums = SKIP
+
+pkgname = rustic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ca275cccde6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thomas Recloux <thomas at recloux dot fr>
+
+pkgname=rustic
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Rustic is a wrapper around the Restic backup program'
+url='https://github.com/bnavetta/rustic'
+license=(MIT)
+arch=(x86_64)
+depends=(restic)
+makedepends=(cargo rust git)
+conflicts=(rustic)
+provides=(rustic)
+source=("git+https://github.com/bnavetta/$pkgname#tag=v$pkgver")
+sha256sums=("SKIP")
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}