summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormoparisthebest2019-01-10 00:30:15 -0500
committermoparisthebest2019-01-10 00:30:15 -0500
commit6f75c550ded47e73bdc789de805436f44791acd4 (patch)
treeb3206f1c2321e232e64492d20dcb9e97b90df522
parentb82f3f3eb62ea9f517d54a8d0427b26978fd9d4c (diff)
downloadaur-rusty-keys-git.tar.gz
cargo fetch in prepare()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4b15fc6369a..0a58c7ba30e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rusty-keys-git
pkgdesc = uinput level keyboard mapper for linux
- pkgver = 0.0.2.r11.g99cf9c4
+ pkgver = 0.0.2.r18.g0ffc169
pkgrel = 1
url = https://code.moparisthebest.com/moparisthebest/rusty-keys
arch = i686
@@ -12,7 +12,7 @@ pkgbase = rusty-keys-git
makedepends = systemd
makedepends = git
depends = libsystemd
- provides = rusty-keys=0.0.2.r11.g99cf9c4
+ provides = rusty-keys=0.0.2.r18.g0ffc169
conflicts = rusty-keys
backup = etc/rusty-keys/keymap.toml
source = rusty-keys-git::git+https://code.moparisthebest.com/moparisthebest/rusty-keys.git
diff --git a/PKGBUILD b/PKGBUILD
index ab9fa53edf13..348ecf07159a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: moparisthebest <admin dot archlinux AT moparisthebest dot com>
pkgname=rusty-keys-git
-pkgver=0.0.2.r11.g99cf9c4
+pkgver=0.0.2.r18.g0ffc169
pkgrel=1
pkgdesc="uinput level keyboard mapper for linux"
url="https://code.moparisthebest.com/moparisthebest/rusty-keys"
@@ -21,6 +21,11 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$pkgname"
+ cargo fetch
+}
+
build() {
cd "$pkgname"
cargo build --release