summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmo Toijala2023-08-12 18:09:18 +0300
committerIsmo Toijala2023-08-12 18:09:18 +0300
commit506ffa686d57456503eb9e0d4cae8f68e89d4140 (patch)
tree8b265df9807ecbd7d68a59f10b5931c1750db3bb
parent8550ff8c4291273b4787aa60b664f1151160e5a5 (diff)
downloadaur-rxvt-unicode-fontspacing-noinc-vteclear-secondarywheel.tar.gz
fix prompt not being at the top when starting
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--starttop.patch10
3 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d084af07308a..373c116f53ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rxvt-unicode-fontspacing-noinc-vteclear-secondarywheel
pkgdesc = Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing, no increment resizing, clear patched to behave like VTEs (keep all lines) and secondaryWheel.
pkgver = 9.31
- pkgrel = 1
+ pkgrel = 2
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = x86_64
license = GPL
@@ -33,6 +33,7 @@ pkgbase = rxvt-unicode-fontspacing-noinc-vteclear-secondarywheel
source = popup-menu-hang.diff
source = clear.patch
source = secondaryWheel.patch
+ source = starttop.patch
sha256sums = aaa13fcbc149fe0f3f391f933279580f74a96fd312d6ed06b8ff03c2d46672e8
sha256sums = afea78dc25db8cd15da9959baf347b0634f4ef62dd3eeaff0c0a3389986b6a3e
sha256sums = 48ef5720d77a870f25737b8f66fe2c1f88a01810013df70cb8155add904288e4
@@ -46,5 +47,6 @@ pkgbase = rxvt-unicode-fontspacing-noinc-vteclear-secondarywheel
sha256sums = 64afd103527ce2cb2a8c51fefd815615afd0a63bbb810f2fb5ea38f6280def03
sha256sums = 9df34ba141a9e32d785f63b050ab82e6e6c745b391c5b16e17bec4dcd4a2b087
sha256sums = 70b2c60887df3b335cd9b26a8ec3964845f75cca98099c7c5a6be4fa74770f57
+ sha256sums = 26bcc874e17db6ab676649dab12f6afd308754fb77673df5e6b5a74d0b89efc7
pkgname = rxvt-unicode-fontspacing-noinc-vteclear-secondarywheel
diff --git a/PKGBUILD b/PKGBUILD
index 89ad35fa39c6..7dcfdb7c4ff1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pkgbase='rxvt-unicode'
pkgname='rxvt-unicode-fontspacing-noinc-vteclear-secondarywheel'
pkgver=9.31
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing, no increment resizing, clear patched to behave like VTEs (keep all lines) and secondaryWheel.'
@@ -46,6 +46,7 @@ source=(
'popup-menu-hang.diff'
'clear.patch'
'secondaryWheel.patch'
+ 'starttop.patch'
)
provides=('rxvt-unicode')
conflicts=('rxvt-unicode')
@@ -64,6 +65,8 @@ prepare() {
patch -p1 -i ../noinc.diff
patch -p1 -i ../clear.patch
patch -p1 -i ../secondaryWheel.patch
+ # https://bugs.archlinux.org/task/77062
+ patch -p1 -i ../starttop.patch
}
build() {
@@ -127,6 +130,7 @@ sha256sums=('aaa13fcbc149fe0f3f391f933279580f74a96fd312d6ed06b8ff03c2d46672e8'
'0ee0434eb84b3ce1f62a4e02c0ba6d0940f4c62477e8982eb9219186feb393e3'
'64afd103527ce2cb2a8c51fefd815615afd0a63bbb810f2fb5ea38f6280def03'
'9df34ba141a9e32d785f63b050ab82e6e6c745b391c5b16e17bec4dcd4a2b087'
- '70b2c60887df3b335cd9b26a8ec3964845f75cca98099c7c5a6be4fa74770f57')
+ '70b2c60887df3b335cd9b26a8ec3964845f75cca98099c7c5a6be4fa74770f57'
+ '26bcc874e17db6ab676649dab12f6afd308754fb77673df5e6b5a74d0b89efc7')
# vim: ts=2 sw=2 et:
diff --git a/starttop.patch b/starttop.patch
new file mode 100644
index 000000000000..51a4979c52b3
--- /dev/null
+++ b/starttop.patch
@@ -0,0 +1,10 @@
+--- a/src/screen.C 2023-08-12 18:06:00.434833329 +0300
++++ b/src/screen.C 2023-08-12 18:06:09.208235384 +0300
+@@ -394,7 +394,6 @@
+ #endif
+ {
+ // wing, instead of wrap
+- screen.cur.row += nrow - prev_nrow;
+
+ do
+ {