summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Ellithorpe2017-05-06 00:51:38 -0700
committerJosh Ellithorpe2017-05-06 00:51:38 -0700
commit25ba380f9bd5f6eb67d6be2068d1c8b223eddba1 (patch)
tree82e10e8d7b13216fdb3e48429662726cfa286fcd
parent963382094926838dc4c5dbb38ad2bd59f7c3e674 (diff)
downloadaur-25ba380f9bd5f6eb67d6be2068d1c8b223eddba1.tar.gz
Fix build for users without golang
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2611011b5377..77febb61c3c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 6 07:25:56 UTC 2017
+# Sat May 6 07:50:46 UTC 2017
pkgbase = s
pkgdesc = Web search from the terminal. Supports over 50 providers including google, github, and stackoverflow.
pkgver = 0.5.10
- pkgrel = 4
+ pkgrel = 5
url = http://github.com/zquestz/s
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8b49580b3fc7..2e368c96a49a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=s
pkgver=0.5.10
-pkgrel=4
+pkgrel=5
pkgdesc="Web search from the terminal. Supports over 50 providers including google, github, and stackoverflow."
arch=('i686' 'x86_64')
url="http://github.com/zquestz/s"
@@ -14,20 +14,23 @@ source=("https://github.com/zquestz/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('8a5ba823d02f495dd1bb150882ddccd2bb082efff4c996b9b43e4cd5599d3df2')
build() {
- cd "$pkgname-$pkgver"
+ mkdir -p "${srcdir}/go/src/github.com/zquestz"
+ export GOPATH="${srcdir}/go"
+ export GOBIN="$GOPATH/bin"
- export GOPATH=~/go
+ mv "$pkgname-$pkgver" "$GOPATH/src/github.com/zquestz/s"
+ cd "$GOPATH/src/github.com/zquestz/s"
go get -u github.com/FiloSottile/gvt
- ~/go/bin/gvt restore
+ $GOBIN/gvt restore
go build .
}
package() {
- cd "$pkgname-$pkgver"
+ cd "${srcdir}/go/src/github.com/zquestz/s"
- install -Dm 775 "$pkgname-$pkgver" \
+ install -Dm 775 "s" \
"${pkgdir}/usr/bin/${pkgname}"
install -Dm 644 "LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"