summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Manenti2023-03-17 13:30:03 +0100
committerAndrea Manenti2023-03-17 13:30:03 +0100
commit029c69b022e99ae33bb4228496eb4739b0bf4a09 (patch)
tree2d0987ff7c7c5e791a5fc77b79ae0208cf14dc4c
parenta492e7a9cf75d60eccca55a25b0e753c439ee17d (diff)
downloadaur-sailboot.tar.gz
Version v1.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 373f647deec9..b1c92e180972 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sailboot
pkgdesc = Highly customizable framework for performing numerical bootstrap computations
- pkgver = 1.1
+ pkgver = 1.2
pkgrel = 1
url = https://gitlab.com/maneandrea/sailboot
arch = any
@@ -13,7 +13,7 @@ pkgbase = sailboot
optdepends = sagemath
optdepends = scalar_blocks-git
optdepends = python-sympy
- source = https://gitlab.com/maneandrea/sailboot/-/archive/v1.1/sailboot-v1.1.tar.gz
- sha256sums = f024743e49296c23db48621e215ff9e979188e9d80d7cd30b5139cace90afaab
+ source = https://gitlab.com/maneandrea/sailboot/-/archive/v1.2/sailboot-v1.2.tar.gz
+ sha256sums = 073d13356e4c4a511c65eeef509a31930d8bca8bd60bcb5373279d6fa46499b3
pkgname = sailboot
diff --git a/PKGBUILD b/PKGBUILD
index 3bc0e2dfe894..70f966233901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrea Manenti <andrea [dot] manenti [at] yahoo [dot] com>
pkgname=sailboot
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="Highly customizable framework for performing numerical bootstrap computations"
arch=(any)
@@ -10,8 +10,8 @@ license=('GPL')
depends=('python-mpmath' 'python-pyparsing' 'sdpb-git')
optdepends=('python-gmpy2' 'sagemath' 'scalar_blocks-git' 'python-sympy')
makedepends=('python-setuptools')
-source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.1/sailboot-v1.1.tar.gz')
-sha256sums=('f024743e49296c23db48621e215ff9e979188e9d80d7cd30b5139cace90afaab')
+source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.2/sailboot-v1.2.tar.gz')
+sha256sums=('073d13356e4c4a511c65eeef509a31930d8bca8bd60bcb5373279d6fa46499b3')
build() {
cd "$pkgname"-v"$pkgver"
@@ -28,8 +28,9 @@ package() {
_pyver=$(python -V | sed -e 's/Python \([0-9]\.[0-9]\+\)\..*/\1/')
- ln -sf /usr/lib/python$_pyver/site-packages/sailboot/main.py "$pkgdir"/usr/bin/sailboot
+ ln -sf /usr/lib/python$_pyver/site-packages/sailboot/sailboot.py "$pkgdir"/usr/bin/sailboot
ln -sf /usr/lib/python$_pyver/site-packages/sailboot/launch.py "$pkgdir"/usr/bin/launch
ln -sf /usr/lib/python$_pyver/site-packages/sailboot/monitor.py "$pkgdir"/usr/bin/monitor
+ ln -sf /usr/lib/python$_pyver/site-packages/sailboot/grid_evaluate.py "$pkgdir"/usr/bin/grid_evaluate
}