summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-21 15:44:40 +0800
committerzxp198210052024-03-21 15:44:40 +0800
commit91c128ca75f74d40311b148fe5a29e0cc67bd962 (patch)
treed57e7afadfff1efb7b32b20d60e873e35727b0aa
parent4742845d493010716864e6bc3d3ee9f33f62607f (diff)
downloadaur-salesforce2sql-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--salesforce2sql.sh5
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a701d434570a..6bf3034ceceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = salesforce2sql-bin
pkgdesc = Electron app to convert a Salesforce org's schema into a similarly shaped database.
pkgver = 0.10.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/acrosman/Salesforce2Sql
arch = x86_64
license = MIT
depends = electron28
- depends = python
+ depends = python>3
depends = python-setuptools
depends = nodejs
provides = salesforce2sql=0.10.0
@@ -15,6 +15,6 @@ pkgbase = salesforce2sql-bin
source = salesforce2sql-0.10.0.rpm::https://github.com/acrosman/Salesforce2Sql/releases/download/v0.10.0/salesforce2sql-0.10.0-1.x86_64.rpm
source = salesforce2sql.sh
sha256sums = 5abdb9dfc1c43bb2fa6cc6e11bc98d049051d7589d3fe123d3184284fc9ccf49
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = salesforce2sql-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7e54ecf8f9ff..b4807739aa77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=salesforce2sql-bin
pkgver=0.10.0
_electronversion=28
-pkgrel=2
+pkgrel=3
pkgdesc="Electron app to convert a Salesforce org's schema into a similarly shaped database."
arch=('x86_64')
url="https://github.com/acrosman/Salesforce2Sql"
@@ -11,7 +11,7 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'python'
+ 'python>3'
'python-setuptools'
'nodejs'
)
@@ -23,11 +23,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('5abdb9dfc1c43bb2fa6cc6e11bc98d049051d7589d3fe123d3184284fc9ccf49'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
}
package() {
diff --git a/salesforce2sql.sh b/salesforce2sql.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/salesforce2sql.sh
+++ b/salesforce2sql.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file