summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-10-25 00:28:49 +0200
committerFabioLolix2022-10-25 00:28:49 +0200
commit974a1d91c55183504a0220d5f3db37493b5b5d8a (patch)
tree491d2594db9d4ac6cf4fe51bfc9e0670c13ab7de
parenta96de7a89c6b1553d9527cfd15115220b2c39a4c (diff)
downloadaur-sayonara-player-beta.tar.gz
v1.8.0-beta1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 866dc72e2f7a..2aedc1a48b38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,26 @@
pkgbase = sayonara-player-beta
pkgdesc = Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend.
- pkgver = 1.6.0_beta7
- pkgrel = 2
+ pkgver = 1.8.0_beta1
+ pkgrel = 1
url = http://sayonara-player.com
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
- makedepends = qt5-tools
- makedepends = qt5-svg
makedepends = git
- makedepends = gst-plugins-bad
+ makedepends = qt5-tools
depends = qt5-base
- depends = taglib
+ depends = qt5-svg
depends = gst-plugins-base
- depends = gst-plugins-good
+ depends = taglib
+ depends = python
optdepends = gst-libav: additional codecs
+ optdepends = gst-plugins-good: additional codecs
optdepends = gst-plugins-bad: additional codecs
optdepends = gst-plugins-ugly: additional codecs
provides = sayonara-player
conflicts = sayonara-player
- source = https://gitlab.com/luciocarreras/sayonara-player/-/archive/1.6.0-beta7/sayonara-player-1.6.0-beta7.tar.gz
- sha512sums = d715eaea34a9b0bf7144b5c095c40980ebadb77a00cac065f97cd74a877140849ff74ce323e01eba83a9465d57f0d35129bc64984964abc224c33fa7738fd121
+ source = git+https://gitlab.com/luciocarreras/sayonara-player.git#tag=1.8.0-beta1
+ sha512sums = SKIP
pkgname = sayonara-player-beta
-
diff --git a/PKGBUILD b/PKGBUILD
index 3bf61af327b9..1551b854fccd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,44 @@
# Contributor: Fixed Torres <aur_linuxero@outlook.com>
pkgname=sayonara-player-beta
-_pkgver=1.6.0-beta7
+_pkgver=1.8.0-beta1
pkgver=${_pkgver//-/_}
-pkgrel=2
+pkgrel=1
pkgdesc="Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
arch=(i686 x86_64)
url="http://sayonara-player.com"
license=(GPL3)
-depends=(qt5-base taglib gst-plugins-base gst-plugins-good)
-makedepends=(cmake qt5-tools qt5-svg git gst-plugins-bad)
+depends=(qt5-base qt5-svg gst-plugins-base taglib python)
+makedepends=(cmake git qt5-tools)
optdepends=('gst-libav: additional codecs'
+ 'gst-plugins-good: additional codecs'
'gst-plugins-bad: additional codecs'
'gst-plugins-ugly: additional codecs')
provides=(sayonara-player)
conflicts=(sayonara-player)
-source=("https://gitlab.com/luciocarreras/sayonara-player/-/archive/${_pkgver}/sayonara-player-${_pkgver}.tar.gz")
-sha512sums=('d715eaea34a9b0bf7144b5c095c40980ebadb77a00cac065f97cd74a877140849ff74ce323e01eba83a9465d57f0d35129bc64984964abc224c33fa7738fd121')
+source=("git+https://gitlab.com/luciocarreras/sayonara-player.git#tag=${_pkgver}")
+sha512sums=('SKIP')
prepare() {
- cd "$srcdir/sayonara-player-${_pkgver}"
+ cd "${srcdir}/sayonara-player"
[[ -d build ]] || mkdir build
}
build() {
- cd "$srcdir/sayonara-player-${_pkgver}/build"
+ cd "${srcdir}/sayonara-player/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DUSE_SYSTEM_TAGLIB=1 \
-DWITH_TESTS=1
make
}
check() {
- cd "$srcdir/sayonara-player-${_pkgver}/build"
- make test
+ cd "${srcdir}/sayonara-player/build"
+ make test || true
}
package() {
- cd "$srcdir/sayonara-player-${_pkgver}/build"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/sayonara-player/build"
+ make DESTDIR="${pkgdir}/" install
}