summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2020-09-10 12:34:40 +0200
committerDavid Runge2020-09-10 12:34:40 +0200
commit4caa0893d8a5a5459336cc58d3ab449c37a02977 (patch)
tree56ee81b57bdf7b84a5879895b5dc60f612d3d5b6
parent2c42458717287fcbbba5f5b2f4919327e8c4970e (diff)
downloadaur-sc3-plugins-git.tar.gz
Upgrade to > 3.11.0
Switch to correct license (GPL2). Switch to current upstream url (on github). Add all direct dependencies. Add all required makedepends. Add sc3-plugins to conflicts and provides (sc3-plugins is in [community]). Update use of cmake to latest guidelines. Update git submodules based on entries in source array in prepare(). Add all available sodeps in package() and the respective packages to makedepends. Add docs. Update maintainer info.
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD63
3 files changed, 63 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fd6049c4f29..6706479ac243 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,31 @@
-# Generated by mksrcinfo v8
-# Sat May 28 09:20:59 UTC 2016
pkgbase = sc3-plugins-git
- pkgdesc = Plugins for SuperCollider (Git version)
- pkgver = 3.7.1.r25.g41a4923
+ pkgdesc = Extension plugins for the SuperCollider3 audio synthesis server.
+ pkgver = 3.11.0.r2.g03b233b
pkgrel = 1
- url = http://supercollider.sourceforge.net/
+ url = https://github.com/supercollider/sc3-plugins
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
+ makedepends = cmake
+ makedepends = fftw
+ makedepends = git
+ makedepends = stk
+ depends = gcc-libs
+ depends = glibc
depends = supercollider
- provides = supercollider-with-extras-git
- conflicts = supercollider-with-extras-git
+ provides = sc3-plugins
+ conflicts = sc3-plugins
source = sc3-plugins::git+https://github.com/supercollider/sc3-plugins
- md5sums = SKIP
+ source = git+https://github.com/timblechmann/nova-simd.git
+ source = git+https://github.com/thestk/stk.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = sc3-plugins-git
+ depends = gcc-libs
+ depends = glibc
+ depends = supercollider
+ depends = libfftw3f.so
+ depends = libstk-4.6.1.so
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..99f4a6428182
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.zst
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 00978a243319..de0669280953 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,55 @@
-# Maintainer: ptrv <mail@petervasil.net>
+# Maintainer: David Runge <dvzrv@archlinux.org>
+# Contributor: ptrv <mail@petervasil.net>
+_name=sc3-plugins
pkgname=sc3-plugins-git
-_name="sc3-plugins"
-pkgver=3.7.1.r25.g41a4923
+pkgver=3.11.0.r2.g03b233b
pkgrel=1
-pkgdesc="Plugins for SuperCollider (Git version)"
-url="http://supercollider.sourceforge.net/"
+pkgdesc="Extension plugins for the SuperCollider3 audio synthesis server."
arch=('i686' 'x86_64')
-license=('GPL')
-depends=('supercollider')
-conflicts=('supercollider-with-extras-git')
-provides=('supercollider-with-extras-git')
-
-source=("${_name}::git+https://github.com/supercollider/sc3-plugins")
-md5sums=('SKIP')
+url="https://github.com/supercollider/sc3-plugins"
+license=('GPL2')
+depends=('gcc-libs' 'glibc' 'supercollider')
+makedepends=('cmake' 'fftw' 'git' 'stk')
+conflicts=('sc3-plugins')
+provides=('sc3-plugins')
+source=("${_name}::git+https://github.com/supercollider/sc3-plugins"
+ "git+https://github.com/timblechmann/nova-simd.git"
+ "git+https://github.com/thestk/stk.git")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$_name"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/Version.//g'
}
-build() {
- cd $srcdir/$_name
- git submodule update --init --recursive .
-
- [ -d bld ] || mkdir bld && cd bld
+prepare() {
+ cd "$_name"
+ git submodule init
+ git config submodule.external_libraries/nova-simd.url "${srcdir}/nova-simd"
+ git config submodule.external_libraries/stk.url "${srcdir}/stk"
+ git submodule update
+}
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DSC_PATH=/usr/include/SuperCollider \
+build() {
+ cd "$_name"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DSC_PATH=/usr/include/SuperCollider/ \
+ -DSYSTEM_STK=ON \
-DSUPERNOVA=1\
- -DAY=1
- make
+ -W no-dev \
+ -B build \
+ -S .
+ make VERBOSE=1 -C build
}
package() {
- cd "$srcdir/$_name/bld"
- make DESTDIR="$pkgdir/" install
+ depends+=('libfftw3f.so' 'libstk-4.6.1.so')
+ cd "$_name"
+ make DESTDIR="$pkgdir/" install -C build
+ install -vDm 644 {{DEVELOPING,README}.md,TODO} \
+ -t "${pkgdir}/usr/share/doc/${pkgname}/"
}