summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeruf2022-09-01 03:21:41 +0200
committerxeruf2022-09-01 03:21:41 +0200
commit67b919543c9c159c4bfe528ac63a7e8e4b0dcfae (patch)
tree00f382572c6e3b99eb4da9421b86e38a7dd5774f
parent9ae75f294621f5b62f1e0e5c8818c86ca8610a13 (diff)
downloadaur-scenic-view.tar.gz
Store properties in XDG_STATE_HOME
scenicView.properties is put into PWD at launch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xscenic-view1
3 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98a3bbd534c7..198b2ea463b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scenic-view
pkgdesc = A tool for analyzing the scenegraph of a JavaFX application
pkgver = 11.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://fxexperience.com/scenic-view/
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = scenic-view
source = scenic-view
source = scenic-view.desktop
sha256sums = 913cbbb3a86e4fa948a09247179eb0d740208a109f73316b135af0ebd938eedc
- sha256sums = 8cf67647a28f2eb2a67bb48283f7b01c5ce866be402df4953b2a2af6d3d50844
+ sha256sums = 69084d16a2aeb71dc08db67ccfc8d467d0508e7f76a2ba0043312ad534f0cd30
sha256sums = 7d1fb4e5a06a081b604e10acef772e809b0aa6a7c56edbfba8bce8af47cabd96
pkgname = scenic-view
diff --git a/PKGBUILD b/PKGBUILD
index 825a02c683e3..92d1f36358bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=scenic-view
pkgver=11.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='A tool for analyzing the scenegraph of a JavaFX application'
arch=('i686' 'x86_64')
url='http://fxexperience.com/scenic-view/'
@@ -10,7 +10,7 @@ source=("https://download.jonathangiles.net/downloads/scenic-view/scenicview-lin
'scenic-view'
'scenic-view.desktop')
sha256sums=('913cbbb3a86e4fa948a09247179eb0d740208a109f73316b135af0ebd938eedc'
- '8cf67647a28f2eb2a67bb48283f7b01c5ce866be402df4953b2a2af6d3d50844'
+ '69084d16a2aeb71dc08db67ccfc8d467d0508e7f76a2ba0043312ad534f0cd30'
'7d1fb4e5a06a081b604e10acef772e809b0aa6a7c56edbfba8bce8af47cabd96')
prepare() {
diff --git a/scenic-view b/scenic-view
index f907587f39e5..7841b26735f2 100755
--- a/scenic-view
+++ b/scenic-view
@@ -1,2 +1,3 @@
#!/bin/sh
+cd "${XDG_STATE_HOME:-$HOME/.local/state}" 2>/dev/null
exec /usr/lib/jvm/java-11-openjdk/bin/java --module-path /usr/lib/jvm/java-11-openjfx/lib --add-modules javafx.web,javafx.fxml,javafx.swing -jar '/usr/share/java/scenic-view/scenicview.jar' "$@"