summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Hasler2015-11-11 20:39:15 +0100
committerMarcel Hasler2015-11-11 20:39:15 +0100
commit59451cffc84cd72ae45d139ed26804e598142277 (patch)
tree4747cc37f4520a229eba8192bc2673876e79c470
downloadaur-59451cffc84cd72ae45d139ed26804e598142277.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rwxr-xr-xscilab.sh3
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bac3ddedea4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = scilab-bin
+ pkgdesc = A scientific software package for numerical computations.
+ pkgver = 5.5.2
+ pkgrel = 1
+ url = https://www.scilab.org
+ arch = x86_64
+ arch = i686
+ license = BSD
+ license = custom:CeCILL
+ source = scilab.sh
+ md5sums = 32bba7f8af6ead4bdacfe40a67d4b30e
+ source_x86_64 = http://www.scilab.org/download/5.5.2/scilab-5.5.2.bin.linux-x86_64.tar.gz
+ md5sums_x86_64 = c24553bc2bf9871d71decd99c2d73d78
+ source_i686 = http://www.scilab.org/download/scilab-bin/scilab-5.5.2.bin.linux-i686.tar.gz
+ md5sums_i686 = 71d794854e85d484b12a8b8c954f03c4
+
+pkgname = scilab-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..730de0f4f4b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Marcel Hasler <mahasler at gmail dot com>
+
+pkgname=scilab-bin
+pkgver=5.5.2
+pkgrel=1
+pkgdesc="A scientific software package for numerical computations."
+arch=("x86_64" "i686")
+license=("BSD" "custom:CeCILL")
+url="https://www.scilab.org"
+
+source=("scilab.sh")
+md5sums=("32bba7f8af6ead4bdacfe40a67d4b30e")
+
+source_x86_64=("http://www.scilab.org/download/${pkgver}/scilab-${pkgver}.bin.linux-x86_64.tar.gz")
+md5sums_x86_64=("c24553bc2bf9871d71decd99c2d73d78")
+
+source_i686=("http://www.scilab.org/download/${pkgname}/scilab-${pkgver}.bin.linux-i686.tar.gz")
+md5sums_i686=("71d794854e85d484b12a8b8c954f03c4")
+
+# Standalone package
+depends=()
+
+package() {
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/opt"
+ cp -r "${srcdir}/scilab-${pkgver}" "${pkgdir}/opt/scilab"
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+
+ install -d "${pkgdir}/usr/share/applications"
+ install -Dm 644 "${srcdir}/scilab-${pkgver}/share/applications/scilab.desktop" "${pkgdir}/usr/share/applications/scilab.desktop"
+
+ install -d "${pkgdir}/usr/share/icons"
+ cp -r "${srcdir}/scilab-${pkgver}/share/icons/hicolor" "${pkgdir}/usr/share/icons/"
+
+ install -Dm 755 scilab.sh "${pkgdir}/usr/bin/scilab"
+}
diff --git a/scilab.sh b/scilab.sh
new file mode 100755
index 000000000000..567d36e5bbaa
--- /dev/null
+++ b/scilab.sh
@@ -0,0 +1,3 @@
+#!/usr/bin/env bash
+LD_LIBRARY_PATH+=:/opt/scilab /opt/scilab/bin/scilab "$@"
+