summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:33:51 +0000
committerAntonio Rojas2019-04-03 06:33:51 +0000
commit5e22d95201097957a52172a43b94ddee873a8f45 (patch)
treeb4027f02bda4f89882ff43d22a44235ad3137455
downloadaur-scim-hangul.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO16
-rw-r--r--2012.patch23
-rw-r--r--PKGBUILD32
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26e587487030
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = scim-hangul
+ pkgdesc = Korean input method module for SCIM
+ pkgver = 0.4.0
+ pkgrel = 4
+ url = https://github.com/choehwanjin/scim-hangul
+ arch = x86_64
+ license = GPL
+ depends = libhangul
+ depends = scim
+ source = scim-hangul-0.4.0.tar.gz::https://github.com/choehwanjin/scim-hangul/archive/v0.4.0.tar.gz
+ source = 2012.patch
+ sha256sums = 3b03a8a31ce662158894eaaf6e9b19c7d3b648fbb2a005a2ca09115277dce638
+ sha256sums = dbb0358ef40c9ccb938571304e9f0844a67b4aeb5f1c8995ea62b2ae54aae9cc
+
+pkgname = scim-hangul
+
diff --git a/2012.patch b/2012.patch
new file mode 100644
index 000000000000..cc837fa5190f
--- /dev/null
+++ b/2012.patch
@@ -0,0 +1,23 @@
+diff -aur old/src/scim_hangul_imengine.cpp new/src/scim_hangul_imengine.cpp
+--- old/src/scim_hangul_imengine.cpp 2012-08-16 01:33:25.996258740 +1000
++++ new/src/scim_hangul_imengine.cpp 2012-08-16 01:33:41.932950046 +1000
+@@ -33,6 +33,7 @@
+ #include <config.h>
+ #endif
+
++#include <unistd.h>
+ #include <cstring>
+ #include <scim.h>
+ #include "scim_hangul_imengine.h"
+diff -aur old/src/scim_hangul_imengine_setup.cpp new/src/scim_hangul_imengine_setup.cpp
+--- old/src/scim_hangul_imengine_setup.cpp 2012-08-16 01:33:25.996258740 +1000
++++ new/src/scim_hangul_imengine_setup.cpp 2012-08-16 01:43:39.823860324 +1000
+@@ -346,7 +346,7 @@
+ for (i = 0; i < n; i++) {
+ const char* name = hangul_ic_get_keyboard_name(i);
+ #if GTK_CHECK_VERSION(2, 24, 0)
+- gtk_combo_box_text_append(GTK_COMBO_BOX_TEXT(combo_box), NULL, name);
++ gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(combo_box), name);
+ #else
+ gtk_combo_box_append_text(GTK_COMBO_BOX(combo_box), name);
+ #endif
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c6bca12fee4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=scim-hangul
+pkgver=0.4.0
+pkgrel=4
+pkgdesc='Korean input method module for SCIM'
+url='https://github.com/choehwanjin/scim-hangul'
+license=('GPL')
+arch=('x86_64')
+depends=('libhangul' 'scim')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/choehwanjin/scim-hangul/archive/v${pkgver}.tar.gz"
+ '2012.patch')
+sha256sums=('3b03a8a31ce662158894eaaf6e9b19c7d3b648fbb2a005a2ca09115277dce638'
+ 'dbb0358ef40c9ccb938571304e9f0844a67b4aeb5f1c8995ea62b2ae54aae9cc')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -p1 -i ../2012.patch
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./bootstrap
+ ./configure --prefix=/usr --enable-skim-support
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}