summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImmae2014-02-23 22:56:44 +0100
committerIsmaƫl Bouya2015-06-10 21:45:22 +0200
commit73ebcccfc7e9d1e1e12ac4fab06847f17e2ea0d1 (patch)
tree3dfff65334e7adfdf35d608e6db3cc870d961141
downloadaur-sclapp.tar.gz
sclapp
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d61f82821cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sclapp
+ pkgdesc = easy-to-use framework for writing simple command-line applications in Python
+ pkgver = 0.5.3
+ pkgrel = 2
+ url = http://www.alittletooquiet.net/software/sclapp/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python
+ source = http://forestbond.com/media/release/sclapp-0.5.3.tar.gz
+ md5sums = 815fe32642213fb63cf29d3ffc0a6e33
+
+pkgname = sclapp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..636ca1883376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Immae <ismael.bouya@normalesup.org>
+# Contributor: Soehartono Hadibowo <kutkinnaku@gmail.com>
+pkgname=sclapp
+pkgver=0.5.3
+pkgrel=2
+pkgdesc="easy-to-use framework for writing simple command-line applications in Python"
+url="http://www.alittletooquiet.net/software/sclapp/"
+license=('GPL')
+depends=('python')
+conflicts=()
+source=(http://forestbond.com/media/release/${pkgname}-${pkgver}.tar.gz)
+arch=('i686' 'x86_64')
+md5sums=('815fe32642213fb63cf29d3ffc0a6e33')
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}