summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Morr2019-11-30 00:43:21 +0100
committerSebastian Morr2019-11-30 00:43:31 +0100
commit96b8a332f1bc3e216e030f8096eb72d2781be2e6 (patch)
treeef4cda0041b27de45ee9db24f16b75fef2292e66
parentef27a8304f8ec094f6fd0eaa87d873fda2d257d8 (diff)
downloadaur-scopes-bin.tar.gz
Update to 0.15
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5143713b2f58..39cf70eda38c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Mon Mar 4 16:40:40 UTC 2019
+# Fri Nov 29 23:43:28 UTC 2019
pkgbase = scopes-bin
pkgdesc = A retargetable programming language & infrastructure
- pkgver = 0.13
+ pkgver = 0.15
pkgrel = 1
url = http://scopes.rocks
arch = x86_64
license = MIT
depends = ncurses
- source = https://bitbucket.org/duangle/scopes/downloads/scopes-0.13-glibc_2.23-linux-x86_64.tar.bz2
- sha256sums = a050e5da113bc79d0b1b066d51d23931e9376dbd627c17d4091e3ac72912f869
+ source = https://bitbucket.org/duangle/scopes/downloads/scopes-0.15-glibc_2.27-linux-x86_64.tar.xz
+ sha256sums = 12bd24666072ae603b6e253cb07d134bc6d0b6ce5bf1073db2484fae3b1e92ef
pkgname = scopes-bin
diff --git a/PKGBUILD b/PKGBUILD
index c1852f1c6738..4ef8909fa489 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian Morr <sebastian@morr.cc>
pkgname=scopes-bin
-pkgver=0.13
+pkgver=0.15
pkgrel=1
pkgdesc="A retargetable programming language & infrastructure"
arch=('x86_64')
@@ -9,17 +9,23 @@ url="http://scopes.rocks"
license=('MIT')
depends=('ncurses')
makedepends=()
-source=(https://bitbucket.org/duangle/scopes/downloads/scopes-$pkgver-glibc_2.23-linux-x86_64.tar.bz2)
-sha256sums=('a050e5da113bc79d0b1b066d51d23931e9376dbd627c17d4091e3ac72912f869')
+source=(https://bitbucket.org/duangle/scopes/downloads/scopes-$pkgver-glibc_2.27-linux-x86_64.tar.xz)
+sha256sums=('12bd24666072ae603b6e253cb07d134bc6d0b6ce5bf1073db2484fae3b1e92ef')
package() {
- cd scopes-$pkgver-glibc_2.23-linux-x86_64
+ cd scopes-$pkgver-glibc_2.27-linux-x86_64
install -Dm755 bin/scopes $pkgdir/usr/bin/scopes
+ install -Dm755 bin/libscopesrt.so $pkgdir/usr/lib/libscopesrt.so
install -Dm644 lib/scopes/core.sc $pkgdir/usr/lib/scopes/core.sc
install -Dm644 lib/scopes/testing.sc $pkgdir/usr/lib/scopes/testing.sc
install -Dm644 lib/scopes/FunctionChain.sc $pkgdir/usr/lib/scopes/FunctionChain.sc
install -Dm644 lib/scopes/Array.sc $pkgdir/usr/lib/scopes/Array.sc
install -Dm644 lib/scopes/glsl.sc $pkgdir/usr/lib/scopes/glsl.sc
install -Dm644 lib/scopes/glm.sc $pkgdir/usr/lib/scopes/glm.sc
+ install -Dm644 lib/scopes/Capture.sc $pkgdir/usr/lib/scopes/Capture.sc
+ install -Dm644 lib/scopes/itertools.sc $pkgdir/usr/lib/scopes/itertools.sc
+ install -Dm644 lib/scopes/Map.sc $pkgdir/usr/lib/scopes/Map.sc
+ install -Dm644 lib/scopes/old_core.sc $pkgdir/usr/lib/scopes/old_core.sc
+ install -Dm644 lib/scopes/spicetools.sc $pkgdir/usr/lib/scopes/spicetools.sc
ln -s /usr/lib/libtinfo.so.6 $pkgdir/usr/lib/libtinfo.so.5
}