summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Spencer2017-06-19 17:42:37 +0100
committerJames Spencer2017-06-19 17:42:37 +0100
commit0ec4b0e39b1e1aa3fb343d72ddfa2642307bcf71 (patch)
tree62a6fc166525730f6eee916f9bc5b806d81faf4f
parent08bcff69ee5e5f8eb0859851ba253e0af4e016b9 (diff)
downloadaur-0ec4b0e39b1e1aa3fb343d72ddfa2642307bcf71.tar.gz
Update to score-p 3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--gcc7.patch23
3 files changed, 37 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a19a3b0092b6..6035017c12d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Sep 22 07:46:09 UTC 2016
+# Mon Jun 19 16:42:32 UTC 2017
pkgbase = scorep
pkgdesc = Highly scalable and easy-to-use tool suite for profiling, event tracing, and online analysis of HPC applications.
- pkgver = 3.0
+ pkgver = 3.1
pkgrel = 1
url = http://www.vi-hps.org/projects/score-p/
arch = i686
@@ -12,8 +12,10 @@ pkgbase = scorep
depends = openmpi
depends = otf2
depends = opari2
- source = http://www.vi-hps.org/upload/packages/scorep/scorep-3.0.tar.gz
- sha1sums = 196d72bfd8e6fb4c9be5e83e5400f69cdd020d71
+ source = http://www.vi-hps.org/upload/packages/scorep/scorep-3.1.tar.gz
+ source = gcc7.patch
+ sha1sums = 54680084955ec8190632f89f508643488a95e4cc
+ sha1sums = c7233fcb8c8ddae0e168f38ef614c439aabb9b84
pkgname = scorep
diff --git a/PKGBUILD b/PKGBUILD
index a001b0f72cad..66c492fb68dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,20 @@
# Maintainer: James Spencer <james.s.spencer@gmail.com>
pkgname=scorep
-pkgver=3.0
+pkgver=3.1
pkgrel=1
pkgdesc="Highly scalable and easy-to-use tool suite for profiling, event tracing, and online analysis of HPC applications."
arch=('i686' 'x86_64')
url="http://www.vi-hps.org/projects/score-p/"
license=('BSD')
depends=('cube-perf' 'openmpi' 'otf2' 'opari2')
-source=(http://www.vi-hps.org/upload/packages/$pkgname/$pkgname-$pkgver.tar.gz)
-sha1sums=('196d72bfd8e6fb4c9be5e83e5400f69cdd020d71')
+source=(http://www.vi-hps.org/upload/packages/$pkgname/$pkgname-$pkgver.tar.gz gcc7.patch)
+sha1sums=('54680084955ec8190632f89f508643488a95e4cc' 'c7233fcb8c8ddae0e168f38ef614c439aabb9b84')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -Np1 -i "${srcdir}/gcc7.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/gcc7.patch b/gcc7.patch
new file mode 100644
index 000000000000..5e5a74256bf2
--- /dev/null
+++ b/gcc7.patch
@@ -0,0 +1,23 @@
+diff -aur scorep-3.1.pristine/src/adapters/compiler/gcc-plugin/scorep_plugin_inst_descriptor.inc.c scorep-3.1.new/src/adapters/compiler/gcc-plugin/scorep_plugin_inst_descriptor.inc.c
+--- scorep-3.1.pristine/src/adapters/compiler/gcc-plugin/scorep_plugin_inst_descriptor.inc.c 2017-05-30 17:26:21.203939989 +0100
++++ scorep-3.1.new/src/adapters/compiler/gcc-plugin/scorep_plugin_inst_descriptor.inc.c 2017-06-19 17:30:42.604985489 +0100
+@@ -194,7 +194,7 @@
+ TREE_TYPE( region_descr_value ) );
+
+ /* Align the struct generously, so that it works for 32 and 64 bit */
+- DECL_ALIGN( region_descr_var ) = 64 * BITS_PER_UNIT;
++ SET_DECL_ALIGN(region_descr_var, 64 * BITS_PER_UNIT );// == 64 * BITS_PER_UNIT;
+ DECL_USER_ALIGN( region_descr_var ) = 1;
+
+ /* The struct is 64 bytes, because of reserved entries */
+diff -aur scorep-3.1.pristine/src/adapters/compiler/gcc-plugin/scorep_plugin_tree-flow.h scorep-3.1.new/src/adapters/compiler/gcc-plugin/scorep_plugin_tree-flow.h
+--- scorep-3.1.pristine/src/adapters/compiler/gcc-plugin/scorep_plugin_tree-flow.h 2017-05-30 17:26:21.203939989 +0100
++++ scorep-3.1.new/src/adapters/compiler/gcc-plugin/scorep_plugin_tree-flow.h 2017-06-19 17:36:32.204975964 +0100
+@@ -23,6 +23,7 @@
+ #include "stringpool.h"
+ #include "basic-block.h"
+ #include "tree-ssa-alias.h"
++#include "tree-vrp.h"
+ #include "tree-ssanames.h"
+ #include "internal-fn.h"
+ #include "gimple-expr.h"