summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarjan Krijan2024-03-04 11:26:05 +0100
committerDarjan Krijan2024-03-04 11:26:05 +0100
commit47b6aa9cbc1f84333b1940656d7ffa1702b4ccce (patch)
tree82b5e661d4c7ab45ed548621d853aad09d62946d
parent9463bd457b68a4e6929db9c5cf73991ee65e6499 (diff)
downloadaur-47b6aa9cbc1f84333b1940656d7ffa1702b4ccce.tar.gz
Add --with-shmem=openmpi and check functionalty.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fa037ff21e2..26f0b2beb516 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scorep
pkgdesc = Highly scalable and easy-to-use tool suite for profiling, event tracing, and online analysis of HPC applications.
pkgver = 8.3
- pkgrel = 2
+ pkgrel = 3
url = http://www.vi-hps.org/projects/score-p/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 094fc4c1a1a7..8fba39754524 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=scorep
pkgver=8.3
-pkgrel=2
+pkgrel=3
pkgdesc="Highly scalable and easy-to-use tool suite for profiling, event tracing, and online analysis of HPC applications."
arch=('i686' 'x86_64')
url="http://www.vi-hps.org/projects/score-p/"
@@ -15,12 +15,28 @@ sha256sums=('76c914e6319221c059234597a3bc53da788ed679179ac99c147284dcefb1574a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --with-mpi=openmpi --with-shmem=no --enable-shared
+
+ local _configure_flags=(
+ --prefix=/usr
+ --with-mpi=openmpi
+ --with-shmem=openmpi
+ --enable-shared
+ )
+ ./configure "${_configure_flags[@]}"
+
make
}
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # -j1 for some Fortran module dependency issue
+ make -j1 --keep-going check |& tee -a make_check.log || true
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+
make DESTDIR="${pkgdir}/" install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}