summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-02-19 20:17:04 +0000
committerMilk Brewster2020-02-19 20:17:04 +0000
commit7a3dc3099ecc6f6722a625c18e20c537f2ba42cb (patch)
tree9d897f4d82451b2b1e2326a93652d611473de6f0
downloadaur-screcord.lv2-git.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b52606c7c359
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = screcord.lv2-git
+ pkgdesc = A mono and a stereo audio capture LV2 plugin.
+ pkgver = r25.e11a771
+ pkgrel = 1
+ url = https://github.com/brummer10/screcord.lv2
+ arch = x86_64
+ groups = lv2-plugins
+ license = GPL
+ depends = libsndfile
+ options = debug
+ options = !strip
+ source = git+https://github.com/brummer10/screcord.lv2
+ md5sums = SKIP
+
+pkgname = screcord.lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6064d2084910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+maintaner="Milkii Brewster <milkii on Freenode IRC>"
+pkgname=screcord.lv2-git
+pkgdesc="A mono and a stereo audio capture LV2 plugin."
+pkgver=r25.e11a771
+pkgrel=1
+epoch=
+arch=(x86_64)
+url="https://github.com/brummer10/screcord.lv2"
+license=(GPL)
+groups=(lv2-plugins)
+depends=(libsndfile)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(debug !strip)
+install=
+changelog=
+source=(git+https://github.com/brummer10/screcord.lv2)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "screcord.lv2"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "screcord.lv2"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "screcord.lv2"
+ # ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "screcord.lv2"
+ make DESTDIR="$pkgdir" install
+}