summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Gulino2018-11-10 09:52:26 +0000
committerMarco Gulino2018-11-10 09:52:26 +0000
commite6a4b9db570aea0784e296d2110f45780bdbafc3 (patch)
tree2a7bc44536bcafb5206544338a0e6b84e760ee63
parenta37a980f96c4c3e0d87beff5a78968e37798785e (diff)
downloadaur-screenrotator-git.tar.gz
Update package
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 794f68a01b1c..41ab78d812d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = screenrotator-git
pkgdesc = Automatic screen rotation daemon for X11
- pkgver = 24b97f7367957857eb373d5b6d24781c386df16d
+ pkgver = r23.1a78a4b
pkgrel = 1
+ epoch = 1
url = https://github.com/GuLinux/ScreenRotator
arch = i686
arch = x86_64
@@ -14,7 +15,7 @@ pkgbase = screenrotator-git
depends = libxi
depends = libxrandr
depends = qt5-sensors
- source = git+https://github.com/GuLinux/screenrotator.git
+ source = screenrotator-git::git+https://github.com/GuLinux/ScreenRotator
sha256sums = SKIP
pkgname = screenrotator-git
diff --git a/PKGBUILD b/PKGBUILD
index 00f5d757d17f..0e8a8a96d343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,37 @@
# Maintainer: Marco Gulino <marco.gulino@gmail.com>
-_pkgname=screenrotator
-pkgname=$_pkgname-git
-pkgver=24b97f7367957857eb373d5b6d24781c386df16d
+pkgname=screenrotator-git
+pkgver=r23.1a78a4b
pkgrel=1
+epoch=1
pkgdesc='Automatic screen rotation daemon for X11'
arch=('i686' 'x86_64')
url='https://github.com/GuLinux/ScreenRotator'
license=('GPL3')
depends=('qt5-base' 'qt5-x11extras' 'libxi' 'libxrandr' 'qt5-sensors')
makedepends=('git' 'cmake' 'qt5-tools')
-source=('git@github.com:GuLinux/ScreenRotator.git')
-source=("git+https://github.com/GuLinux/$_pkgname.git")
+source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
-_gitname='screenrotator'
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ install -d build
}
build() {
- mkdir -p build
- cd build
- cmake "$srcdir/$_pkgname" \
+ cd "$srcdir/$pkgname/build"
+ cmake ..\
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd build
+ cd "$srcdir/$pkgname/build"
make DESTDIR="$pkgdir" install
}